AUTODESK TRUST CENTER

Security advisory

Advisories are used to communicate information related to vulnerabilities identified with Autodesk® products and services. This includes any fixes or workarounds that are applicable to the affected product.

Multiple Vulnerabilities in Autodesk AutoCAD Desktop Software

Autodesk ID: ADSK-SA-2024-0004
Product, Service, Component: Autodesk AutoCAD, Advance Steel and Civil 3D
Impact: Out-of-Bounds write, Stack-based Overflow, Heap based Overflow, Use-After-Free, Memory Corruption, Untrusted Pointer Dereference, Heap-based Buffer Overflow, Uninitialized Variable
Severity: High
Original Publish: 2/29/2024
Last Revised: 4/18/2024

Severity

CVSS 3.0 Score

Impact

Low

0.1 - 3.9

A vulnerability where scope and impact of exploitation is restricted and the ability to exploit is extremely difficult.

Medium

4.0 - 6.9

A vulnerability where exploitation is mitigated by factors such as difficulty to exploit, default configuration or ease of identification.

High

7.0 - 8.9

A vulnerability, which if exploited, would directly impact the confidentiality, integrity or availability of user’s data or processing resources.

Critical

9.0 - 10

A vulnerability, which if exploited, would allow remote execution of malicious code without user action.

Summary

Autodesk AutoCAD and certain AutoCAD-based products may be affected by Out-of-Bounds write, Stack-based Overflow, Heap based Overflow, Use-After-Free, Memory Corruption, Untrusted Pointer Dereference, Heap-based Buffer Overflow, and Uninitialized Variable vulnerabilities. Exploitation of these vulnerabilities may lead to code execution.

Description

The details of the vulnerabilities are as follows:

  1. CVE-2024-0446: A maliciously crafted STP, CATPART or MODEL file when parsed in ASMKERN228A.dll and ASMdatax229A.dll through Autodesk applications can force an Out-of-Bound Write. A malicious actor can leverage this vulnerability to cause a crash, read sensitive data, or execute arbitrary code in the context of the current process.
  2. CVE-2024-23120: A maliciously crafted STP and STEP file when parsed in ASMIMPORT228A.dll and ASMIMPORT229A.dll and through Autodesk applications can force an Out-of-Bound Write. A malicious actor can leverage this vulnerability to cause a crash, read sensitive data, or execute arbitrary code in the context of the current process.
  3. CVE-2024-23121: A maliciously crafted MODEL file when parsed in libodxdll.dll through Autodesk applications can force an Out-of-Bound Write. A malicious actor can leverage this vulnerability to cause a crash, read sensitive data, or execute arbitrary code in the context of the current process.
  4. CVE-2024-23122: A maliciously crafted 3DM file when parsed in opennurbs.dll through Autodesk applications can force an Out-of-Bound Write. A malicious actor can leverage this vulnerability to cause a crash, read sensitive data, or execute arbitrary code in the context of the current process.
  5. CVE-2024-23123: A maliciously crafted CATPART file when parsed in CC5Dll.dll and ASMBASE228A.dll through Autodesk applications can force an Out-of-Bound Write. A malicious actor can leverage this vulnerability to cause a crash, read sensitive data, or execute arbitrary code in the context of the current process.
  6. CVE-2024-23124: A maliciously crafted STP file when parsed in ASMIMPORT228A.dll through Autodesk applications can force an Out-of-Bound Write. A malicious actor can leverage this vulnerability to cause a crash, read sensitive data, or execute arbitrary code in the context of the current process.
  7. CVE-2024-23125: A maliciously crafted SLDPRT file when parsed ODXSW_DLL.dll through Autodesk applications can be used to cause a Stack-based Overflow. A malicious actor can leverage this vulnerability to cause a crash, read sensitive data, or execute arbitrary code in the context of the current process.
  8. CVE-2024-23126: A maliciously crafted CATPART file when parsed CC5Dll.dll through Autodesk applications can be used to cause a Stack-based Overflow. A malicious actor can leverage this vulnerability to cause a crash, read sensitive data, or execute arbitrary code in the context of the current process.
  9. CVE-2024-23127: A maliciously crafted MODEL, SLDPRT, or SLDASM file, when parsed in ODXSW_DLL.dll and libodxdll.dll through Autodesk applications, can be used to cause a Heap-based Overflow. A malicious actor can leverage this vulnerability to cause a crash, read sensitive data, or execute arbitrary code in the context of the current process.
  10. CVE-2024-23128: A maliciously crafted MODEL file, when parsed in libodxdll.dll and ASMDATAX229A.dll through Autodesk applications, can lead to a memory corruption vulnerability by write access violation. This vulnerability, in conjunction with other vulnerabilities, can lead to code execution in the context of the current process.
  11. CVE-2024-23129: A maliciously crafted MODEL 3DM, STP or SLDASM files in opennurbs.dll when parsed through Autodesk applications can lead to a memory corruption vulnerability by write access violation. This vulnerability in conjunction with other vulnerabilities could lead to code execution in the context of the current process.
  12. CVE-2024-23130: A maliciously crafted SLDASM, or SLDPRT files in ODXSW_DLL.dll when parsed through Autodesk applications can lead to a memory corruption vulnerability by write access violation. This vulnerability in conjunction with other vulnerabilities could lead to code execution in the context of the current process.
  13. CVE-2024-23131: A maliciously crafted STP file, when parsed in ASMIMPORT229A.dll, ASMKERN228A.dll, ASMkern229A.dll or ASMDATAX228A.dll through Autodesk applications, can lead to a memory corruption vulnerability by write access violation. This vulnerability, in conjunction with other vulnerabilities, can lead to code execution in the context of the current process.
  14. CVE-2024-23132: A maliciously crafted STP file in atf_dwg_consumer.dll when parsed through Autodesk applications can lead to a memory corruption vulnerability by write access violation. This vulnerability in conjunction with other vulnerabilities could lead to code execution in the context of the current process.
  15. CVE-2024-23133: A maliciously crafted STP file in ASMDATAX228A.dll when parsed through Autodesk applications can lead to a memory corruption vulnerability by write access violation. This vulnerability in conjunction with other vulnerabilities could lead to code execution in the context of the current process.
  16. CVE-2024-23134: A maliciously crafted IGS file in tbb.dll when parsed through Autodesk AutoCAD can be used in user-after-free vulnerability. This vulnerability, along with other vulnerabilities, could lead to code execution in the current process.
  17. CVE-2024-23135: A maliciously crafted SLDPRT file in ASMkern228A.dll when parsed through Autodesk applications can be used in user-after-free vulnerability. This vulnerability, along with other vulnerabilities, could lead to code execution in the current process.
  18. CVE-2024-23136: A maliciously crafted STP file in ASMKERN228A.dll when parsed through Autodesk applications can be used to dereference an untrusted pointer. This vulnerability, along with other vulnerabilities, could lead to code execution in the current process.
  19. CVE-2024-23137: A maliciously crafted STP or SLDPRT file in ODXSW_DLL.dll when parsed through Autodesk applications can be used to uninitialized variables. This vulnerability, along with other vulnerabilities, can lead to code execution in the current process.

Affected Products

 

Item

Impacted Versions

Mitigated Versions

Update Source

Autodesk AutoCAD

2025, 2024, 2023, 2022, 2021

2025.0.1, 2024.1.3, 2023.1.5,
2022.1.4, 2021.1.4

Autodesk Access or Accounts Portal

Autodesk AutoCAD Architecture

2025, 2024, 2023, 2022, 2021

2025.0.1, 2024.1.3, 2023.1.5,
2022.1.4, 2021.1.4**

Autodesk Access or Accounts Portal

Autodesk AutoCAD Electrical

2025, 2024, 2023, 2022, 2021

2025.0.1, 2024.1.3, 2023.1.5,
2022.1.4, 2021.1.4**

Autodesk Access or Accounts Portal

Autodesk AutoCAD Map 3D

2025, 2024, 2023, 2022, 2021

2025.0.1, 2024.1.3, 2023.1.5,
2022.1.4, 2021.1.4**

Autodesk Access or Accounts Portal

Autodesk AutoCAD Mechanical

2025, 2024, 2023, 2022, 2021

2025.0.1, 2024.1.3, 2023.1.5,
2022.1.4, 2021.1.4**

Autodesk Access or Accounts Portal

Autodesk AutoCAD MEP

2025, 2024, 2023, 2022, 2021

2025.0.1, 2024.1.3, 2023.1.5,
2022.1.4, 2021.1.4**

Autodesk Access or Accounts Portal

Autodesk AutoCAD Plant 3D

2025, 2024, 2023, 2022, 2021

2025.0.1, 2024.1.3, 2023.1.5,
2022.1.4, 2021.1.4**

Autodesk Access or Accounts Portal

Autodesk Civil 3D

2025, 2024, 2023, 2022, 2021

2025.0.1,2024.1.3, 2023.1.5,
2022.1.4, 2021.1.4**

Autodesk Access or Accounts Portal

Autodesk Advance Steel

2025, 2024, 2023, 2022, 2021

2025.0.1, 2024.1.3, 2023.1.5,
2022.1.4, 2021.1.4**

Autodesk Access or Accounts Portal

*Note: Product list table contents subject to change.

** Note: Users of Autodesk Advance Steel, Autodesk Civil 3D, and the specialized toolsets of AutoCAD need to install either product update(s) listed above or a more recent product version. These security fixes are not included in the updates specific to individual toolsets.

Recommendations

Autodesk strongly recommends that users of the listed supported versions of AutoCAD, Advance Steel, Civil 3D and the specialized toolsets of AutoCAD install the latest updates, as applicable, via Autodesk Access or the Accounts Portal. As a general best practice, we also recommend that customers only open files (3dm, abc, CATPart, iges, igs, model, prt, sldasm, sldprt, step, stp, x_t) from trusted sources.

Customers using previous versions that no longer qualify for full support should plan to upgrade to a supported version as soon as possible to avoid downtime and potential security vulnerabilities. Visit the Autodesk Knowledge Network for more information about previous version support.

Acknowledgements

We thank the following researcher for reporting the relevant issues and for working with Autodesk to help protect our customers:

  • Mat Powell of Trend Micro Zero Day Initiative for reporting CVE-2024-0446, CVE-2024-23120, CVE-2024-23121, CVE-2024-23122, CVE-2024-23123, CVE-2024-23124, CVE-2024-23125, CVE-2024-23126, CVE-2024-23127, CVE-2024-23128, CVE-2024-23129, CVE-2024-23130, CVE-2024-23131, CVE-2024-23132, CVE-2024-23133, CVE-2024-23134, CVE-2024-23135, CVE-2024-23136, CVE-2024-23137

Revision History

Revision

Date

Description

1.0

2/29/2024

Initial Release of the Security Advisory

1.1

3/20/2024

Updated Affected Table for AutoCAD 2024, 2022 and 2021 Update

1.2

4/18/2024

Update Affected Table for AutoCAD 2025 Update

Disclaimer

INFORMATION IN THIS DOCUMENT IS PROVIDED “AS IS” IN CONNECTION WITH AUTODESK PRODUCTS. AUTODESK AND/OR ITS RESPECTIVE SUBSIDIARIES, AFFILIATES, SUPPLIERS AND LICENSORS AND ITS AND THEIR DIRECTORS, OFFICERS, EMPLOYEES, AGENTS, AND REPRESENTATIVES MAKE NO REPRESENTATIONS ABOUT THE SITE, ANY PRODUCTS AND SERVICES CONTAINED ON THE SITE OR THE SUITABILITY OF THE INFORMATION CONTAINED IN THE MATERIALS, INFORMATION, CONTENT, DOCUMENTS, AND RELATED GRAPHICS PUBLISHED ON THIS SITE FOR ANY PURPOSE. THE SITE, ANY PRODUCTS OR SERVICES (INCLUDING WITHOUT LIMITATION, THIRD PARTY PRODUCTS AND SERVICES) OBTAINED THROUGH THE SITE, AND ALL SUCH INFORMATION, CONTENT, DOCUMENTS, AND RELATED GRAPHICS ARE PROVIDED FOR YOUR USE AT YOUR OWN RISK AND "AS IS" WITHOUT WARRANTY OF ANY KIND. AUTODESK AND/OR ITS RESPECTIVE SUBSIDIARIES, AFFILIATES, SUPPLIERS AND LICENSORS HEREBY DISCLAIM ALL WARRANTIES AND CONDITIONS WITH REGARD TO THIS SITE, SUCH PRODUCTS AND SERVICES AND SUCH INFORMATION, CONTENT, DOCUMENTS, AND RELATED GRAPHICS, INCLUDING ALL IMPLIED WARRANTIES AND CONDITIONS OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE, AND NON-INFRINGEMENT.

© 2024, Autodesk, Inc.