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How to import and export data from external software packages.
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Data transfer

INTRODUCTION
Learn the theory behind CAD data transfer and how it works within AliasStudio.
It is not necessary to read this information to complete a data transfer. However,
it may help you understand how data can be transferred successfully.
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Introduction to Data Transfer
Explains the general workflow of data transfer used in AliasStudio.
AliasStudio provides translators of industry standard data exchange formats as
well as DirectConnect’s file formats.
Data transfer workflow
1

Set your model environment to match your CAD system.
Preferences > Construction options > Construction Preset

2

Create your model.
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Use evaluation tools to verify that the geometry is suitable for data transfer.

●

Evaluate > Check model
Use this tool to analyze a model (or portions of a model) for geometry that
has particular characteristics. Depending on the options you choose, a report
is generated describing the contents of a model and the results of the checks
performed.
See Prepare a model for import into CAD systems (page 986) for
a sample workflow.

●

Evaluate > Continuity > Surface continuity
This tool checks the position, tangent and curvature continuity between and
within surfaces.

●

Locators > Deviation

Use these tools to check the maximum distance between surface boundaries
in AliasStudio to confirm the integrity of the model before transferring it to the
target CAD system.
●

Surface Edit > Stitch > Shell stitch
This tool enables you to create a valid solid model topology within
AliasStudio. Stitching surfaces within AliasStudio creates a shell. When the
shell is exported to a downstream (CAD)Ssystem,
= Surfaceit includes an extra layer of
information.
E = Edge
V = Vertex
The stitching process also identifies surface
boundaries that exceed the
prescribed tolerances. These problems can then be corrected by the
designer prior to the translation of the data.

Save the original model before stitching.

Stitching is not required prior to transferring Unigraphics , Pro/ENGINEER, or
CATIA files. If the geometry is stitched, it comes into the target system with
topology information. If it is not stitched prior to transfer, the geometry comes
into the target system as NURBS geometry.

4

Learn how Solid Modeling Theory works
Learn how geometric and topological data works together to form a solid model.
You should be familiar with the concepts of solid model data types to understand
how geometric and topological data work together to form a complete model.
●

Geometric data
Surfaces contain the geometric data of a solid model. The geometric data
describes the basic shape of an object and can be represented using
NURBS ( Non-Uniform Rational B-Splines).

●

Topological data
Loops, edges, and vertices contain the topological relationships between the
individual surfaces that form the solid model. Topological data describes how
the geometric components are connected together. In solid modeling
terminology, surfaces are called faces, and each face is made up of loops,
edges, and vertices.

How does it work
The following is an example of a solid model of a cube which has six surfaces
(faces) labeled S1 to S6 which form the geometrical and topological information
required to define it as a solid model. Each of the surfaces has a loopset, but in
this case each surface has only one loop. The loop for S1 has four edges and
four vertices.

S6
S3

E1
V1

S4

S1

E4

V2
E2

S2
V4
S1

V3
E3

S5

The edges are used to connect two loops from adjacent surfaces. The vertices
are used to connect two or more edges.
This solid box consists of six surfaces, twelve edges, and eight vertices that form
the geometrical and topological information required to define it as a solid model.
For example, if a hole is placed in the box through S1 and S6, S1 and S6 would
each have a loopset containing two loops.

5

Learn the Solid Modeling workflow
Learn what requirements are expected in a solid modeler.
Creating solid geometry from imported AliasStudio models is a common workflow
when integrating AliasStudio and CAD systems. When exporting the model from
AliasStudio, you must ensure that the geometry is built to the correct tolerance
and that it can also be stitched. Stitching in AliasStudio identifies gaps between
surfaces so that you can repair the geometry before exporting the file.
During stitching, the surfaces are twinned. This means that the surface
boundaries may be split to accommodate adjacent surfaces, and periodic
geometry is detached into multiple surfaces. For this reason, you should save the
AliasStudio wire file before stitching so that if further modifications to the
AliasStudio model are required, the construction history will be intact.

A stitched geometry saved to an AliasStudio wire file cannot be unstitched to
its original state.

What happens when you import data into a solid modeler
When you import a AliasStudio model into a solid modeler, you provide the
geometric and topological information of the model. When creating a solid model,
the solid modeler system creates a valid data base from the supplied data, and
the supplied data must satisfy the solid modeler's rules for topological and
geometric data.
The topology of a model defines how each surface relates to all other surfaces in
the model. The important element of getting the topology right for data exchange
to solid modelers is that an edge on one surface must have a “twin” edge on the
adjacent surface. Edges are defined by natural surface boundaries or trimmed
surface boundaries.

You can transfer surfaces and complete the stitch procedure in a
CAD system or first stitch them in AliasStudio and then export the
data.
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Learn about the tolerance requirements for Solid Modeling
Learn how to achieve the tolerances required in solid modeling.
To achieve the tolerance required by solid modeling, it is important to manage the
modeling units and tolerances when creating your model. The millimeter (mm) or
inch is generally used as the base linear unit. Standards for tolerances have been
developed as they apply to engineering-based CAD systems.

If you are not sure of the standards your companies or clients use, ask your
CAD system manager. Set up your units and tolerances at the beginning of
your modeling session and save them as a preset in the Construction
Options box. The next time AliasStudio is opened, the preset that was in use
when AliasStudio was last exited, will be in effect.

To successfully join or align surfaces in the target system, the gap between the
surfaces of your model must be less than the accuracy defined within the solid
modeler.

To specify various tolerances choose Preferences > Constructions
options.

Rational and non-rational geometry concerns for data transfer
In the Preferences > Constructions options window, you can specify whether or
not the new geometry being created will contain the rational or non-rational
component.
Rational geometry contains CVs that do not have a uniform weight, while the CVs
of non-rational geometry all have the same weight. Some CAD systems that do
not support rational geometry will rebuild the rational element of geometry upon
import. This will change the intended design and therefore the user should know
ahead of time whether rational geometry is supported by the target CAD system.
Rational fillets are created with fewer isoparametric curves and the tangency to
the adjacent surface can be up to ten times more accurate. While this is an
advantage in AliasStudio, it is even more apparent when the geometry has been
transferred to a solid modeler. The closer adjacent surfaces are to exact
tangency, the more usable the imported AliasStudio data is in downstream
operations. For example, the further the geometry can be offset during the
thickening operation.
Once the above conditions have been met, you should try several sample
translations to verify that the geometry is being passed from AliasStudio
successfully. Before modeling a project in AliasStudio that is intended for export,
you should model several sample pieces of geometry in mock modeling
situations, then transfer them and attempt the stitching operation in the target
CADS system. This will confirm that the model, when completed, will transfer
successfully.
Whether you are creating a model, verifying a model, or debugging a translation,
there are a number of tools in AliasStudio you can use to check the quality of the
geometry you have created. The most useful tools are the surface continuity
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checker (Evaluate > Continuity > Surface continuity) and the Min/Max
measurement tools (Locators > Deviation). Use these tools to check the
maximum distance between surface boundaries in AliasStudio to confirm the
integrity of the model before transferring it to the target CAD system.
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Learn how to get the topology right before transferring data
Learn how to get the topology correct for solid modeling.
The Surface Edit > Stitch tools in AliasStudio creates a valid solid model
topology.
●

Stitching surfaces can greatly improve the data transfer to a solid modeler.

●

The stitching process also identifies surface boundary gaps that exceed your
tolerances.

●

The stitching process identifies duplicate surfaces in the model and unifies
the direction of the surface normals of the completed shell.

The following illustration shows three individual surfaces (labeled S1, S2 and
S3). The edges of each surface are represented by dashed lines.
S1

S2

S3

When models are constructed using the AliasStudio advanced surface tools
(Swept, Rail Surface and Square), it is common to create a number of smaller
surfaces along the edge of one larger surface. This modeling technique does not
create the twin edges required for a solid model. Stitching adds this information.

Some modeling techniques, such as Trim, Intersect and Round, create twin
edges.

9

REQUIREMENTS AND WORKFLOWS
FOR CAD PACKAGES
Review the requirements and data transfer workflows.
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Inventor
DWG, IGES or STEP file formats can be used to transfer AliasStudio models to or
from Inventor.
Inventor Requirements
●
Inventor 2008 or Inventor Professional.
●

An AliasStudio software product.

Model Preparation
>

Units

When working in AliasStudio set the Units to be the same (mm or inches) as what
is used in the Inventor model.
>

Geometry/Topology

When using AliasStudio two types of model information can be sent to and read
by Inventor. Those two types are geometry information and topology information.
The Studio-created IGES file includes only the description of the geometry
information. The Studio-created STEP and DWG file supports both the geometry
information as well as the topology information.
The geometric data describes the basic shape of the object and in both
AliasStudio and Inventor, geometric data is represented using NURBS.
Topological data describes how the geometric components are connected
together to form a solid. The AliasStudio STEP file format has advantages over
IGES when transferring AliasStudio models to Inventor because there is more
information describing the model that is being transferred. THe preferred method
is DWG.
>
●

Tolerances
In the Construction Settings window:
Set Preferences > Construction options - Construction Preset to Inventor.

>

Information specific to DWG

DWG Export will heal the model and make it ready for use in Inventor.
>

Information specific to Granite

Curve Fit Distance is the key to translation quality. The recommended
tolerance in the Preferences > Construction options - Construction
Preset - Tolerances > Fitting is based on testing done translating models
between AliasStudio and Inventor.
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Maximum Gap Distance is the value that is used to check if the adjacent
boundaries are built closely enough to each other.They should never be
smaller than the Curve Fit Distance.
>

Get the geometry right

To achieve the tolerance required by solid modeling it's important to manage the
modeling units and tolerances when creating your model. Most engineering
organizations use the millimeter or inches units as the base linear unit and have
developed standards for tolerances that they apply to their CAD systems.
If you are not clear as to which standards your companies or clients use, seek out
your CAD system manager. Set up your units and tolerances at the beginning of
your modeling session and save them in your usr_options file.
Whether you are creating a model, verifying a model, or debugging a translation,
there are a number of tools within AliasStudio to check the quality of the
geometry you have created. The most useful tool is the min/max measurement
tool in the Locators menu. Use this tool to check the maximum distance between
any two surface boundaries.
To import AliasStudio models into Inventor
Advanced data sharing techniques
The following are some suggestions for AliasStudio modeling that provide
enhanced inter-operability with Inventor.
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Pro/ENGINEER
PTC Granite™, IGES or STEP file formats can be used to transfer AliasStudio
models to or from Pro/ENGINEER Wildfire.
Pro/ENGINEER Requirements
Pro/ENGINEER Wildfire 1.0 or 2.0, IGES, STEP, or Granite translators.

●
●

An AliasStudio software product.

Model Preparation
>

Units

When working in Pro/ENGINEER set the Units to be the same as what was used
in the AliasStudio model.
>

Geometry/Topology

When using AliasStudio two types of model information can be sent to and read
by Pro/ENGINEER. Those two types are geometry information and topology
information.
The Studio-created IGES file includes only the description of the geometry
information. The Studio-created STEP and Granite file supports both the
geometry information as well as the topology information.
The geometric data describes the basic shape of the object and in both
AliasStudio and Pro/ENGINEER, geometric data is represented using NURBS.
Topological data describes how the geometric components are connected
together to form a solid. The AliasStudio STEP file format has advantages over
IGES when transferring AliasStudio models to Pro/ENGINEER because there is
more information describing the model that is being transferred.
>
●

Tolerances
In the Construction Settings window:
Set Preferences > Construction options - Construction Preset to Pro/
ENGINEER.

>
●

Information specific to IGES
AliasStudio sets and IGES levels.
AliasStudio set information is only exported in files for IGES, VDAIS, or
JAMA-IS, if the option Level Mapping is set to SET. If an AliasStudio set is
given a name of the form of LEVEL<n>, where <n> is an IGES level number
(and greater than 0), then the corresponding IGES entity for each member of
the AliasStudio set is assigned to level<n> in the IGES file. For example, the
IGES entities corresponding to each member of the set LEVEL245 is
assigned to level 245 in the IGES file.
If an AliasStudio object is a member of several multisets that conform to this
naming convention, then the IGES file contains a Property Entity 406 form 1
(Definition Levels) listing the IGES levels to which the corresponding entity
belongs.

13

>

Information specific to Granite

The translation time of rational geometry (for example, exact radius
surfaces) is longer than the translation of non-rational geometry. In
AliasStudio you can create non-rational surfaces and translate them into
PTC Granite.

Curve Fit Distance is the key to translation quality. The recommended
tolerance in the Preferences > Construction options - Construction
Preset - Tolerances > Fitting is based on testing done translating models
between AliasStudio and
Pro/ENGINEER.

Maximum Gap Distance is the value that is used to check if the adjacent
boundaries are built closely enough to each other.They should never be
smaller than the Curve Fit Distance.

Workflow
Before transferring geometry between AliasStudio and Pro/ENGINEER, you
should consider the purpose of the transfer to plan an appropriate workflow.
When you import your AliasStudio model into Pro/ENGINEER, you provide the
geometric and topological information of the model. When creating a solid model,
the Pro/ENGINEER system must create a valid Pro/ENGINEER data base from
the AliasStudio supplied data. The AliasStudio supplied data must satisfy the Pro/
ENGINEER's rules for topological and geometric data.
>

Get the geometry right

To achieve the tolerance required by solid modeling it's important to manage the
modeling units and tolerances when creating your model. Most engineering
organizations use the millimeter or inches units as the base linear unit and have
developed standards for tolerances that they apply to their CAD systems.
If you are not clear as to which standards your companies or clients use, seek out
your CAD system manager. Set up your units and tolerances at the beginning of
your modeling session and save them in your usr_options file.

The maximum distance or gap between the surfaces of your model must be
less then the accuracy defined within Pro/ENGINEER for successful joining
of surfaces. The Pro/ENGINEER system defines accuracy as a value less
then the ratio of the length of the smallest edge of a part divided by the
length of the largest side of a part.
You can lower the part accuracy to successfully join surfaces when the gap
exceeds the required tolerance. However, we recommend that your
AliasStudio models are constructed to within the accuracy defined by the
engineering requirements of your organization.

A recommended tolerance to maintain during transfer from AliasStudio to Pro/
ENGINEER is dependent on the size of the part being described. AliasStudio
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uses an absolute tolerance system to describe geometry which means that every
piece of geometry in a particular wire file is built to plus or minus a given value
(tolerance). Pro/ENGINEER uses a system of relative tolerance, referring to the
fact that the acceptable gap between pieces of geometry is based on the relative
size of the geometry.
The default accuracy in Pro/ENGINEER is set to .0012 and the range available is
.01 to .0001. Using the default accuracy, the maximum allowable distance
between two surfaces when the longest edge of the surface is five inches would
be less than 5 * .0012 = .006 inches. You must create surfaces in AliasStudio that
adhere to this accuracy to be successful in creating a Pro/ENGINEER solid
model.
Whether you are creating a model, verifying a model, or debugging a translation,
there are a number of tools within AliasStudio to check the quality of the
geometry you have created. The most useful tool is the min/max measurement
tool in the Locators menu. Use this tool to check the maximum distance between
any two surface boundaries.
>

Get the topology right

The AliasStudio stitching operation is recommended to be done on geometry
being prepared for transfer to Pro/ENGINEER.
The Surface Edit > Stitch> Shell Stitch feature within AliasStudio creates a valid
solid model topology within the AliasStudio modeling environment. The stitching
of surfaces within AliasStudio greatly improves the robustness of the interface to
Pro/ENGINEER. The stitching process also identifies surface boundaries that
exceed the prescribed tolerances. These problems can then be corrected by the
designer prior to the translation of the data to Pro/ENGINEER.
In addition, the stitching process also identifies duplicate surfaces in the model
and orients the surface normals of the completed shell.
When models are constructed using the advance surface tools (swept, Rail
Surface and square) it is quite common to create a number of smaller surfaces
along the edge of one larger surface. This modeling technique does not create
the twin edges required for a solid model. The stitching feature will automatically
create the twin edge topology required by Pro/ENGINEER.
One case that cannot be solved topologically is the closed or periodic surface (a
primitive sphere is an example of a closed surface). The reason for this is that in
most solid modelers, a face cannot be joined to itself. The presence of closed or
periodic geometry in AliasStudio (not true for Granite) is another reason that
geometry intended for transfer to Pro/ENGINEER must be stitched before export.
Using stitch has the same effect as detaching the geometry to create two
surfaces before writing the IGES or STEP file for Pro/ENGINEER.
To import AliasStudio models into Pro/ENGINEER
>

Define Absolute Tolerance Process (STEP and IGES only)

Before importing any foreign geometry (such as models created in AliasStudio)
the Pro/ENGINEER user can change from the default Relative Tolerancing
process to the Absolute Tolerance process. Before a foreign model (that is
created anywhere other than Pro/ENGINEER) is imported into Pro/ENGINEER,
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the desired absolute tolerance can be set to the value that the incoming model
was built to.
For example if the Curve Fit Distance in AliasStudio was set to 0.002mm, then
the Absolute Tolerance in the Pro/ENGINEER work session should be set to
0.002mm.
This option can be enabled by writing the line:enable_absolute_accuracy
yes into the config.pro file of the working directory.
Once the option is enabled you must go to the Setup section of the Pro/
ENGINEER application and choose Absolute Accuracy, and set the units and
numerical value of the tolerance you wish to work at, each time a new part is
created.
This is important to ensure that the AliasStudio-created model can be used in
further downstream operations in Pro/ENGINEER.
Advanced data sharing techniques
The following are some suggestions for AliasStudio modeling that provide
enhanced inter-operability with Pro/ENGINEER.
>

Export individual “Features” from AliasStudio

Because Pro/ENGINEER creates each element of a model as a feature, it can be
very useful to import components of the AliasStudio model as individual export
files that can be manipulated in Pro/ENGINEER as individual import Features.
Major components of your AliasStudio model can be transferred separately so
that they can be used to construct individual features within Pro/ENGINEER.
The advantage of this technique is that individual features can be “reordered” in
Pro/ENGINEER to give added flexibility to the engineer. The Feature > Reorder
command allows the user of Pro/ENGINEER to modify the sequence feature
construction. This is useful during the engineering process. Additional
“mechanical” features are added to the industrial design model and the result is
based on geometry previously created.
>

Surface replacement

The surface replacement technique can be very useful when the model is a mix
of mechanical elements defined by an engineer and styling elements defined by
an industrial designer. By replacing the styling elements of a Pro/ENGINEER
model all of the parametric/feature information is retained for the mechanical
elements. This allows for continued parametric editing, automatic dimensioning,
and so on.
>

Exporting assemblies from Pro/ENGINEER in IGES format

When exporting assemblies from Pro/ENGINEER, there are four types of IGES
output available: Flat, One Level, All Levels and All Parts.
Flat
With the Flat option, Pro/ENGINEER exports the entire geometry of the assembly
in a single IGES file. All components are transformed into model space before
exporting, but there will be no hierarchy contained in the IGES file. All geometry
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of the assembly exists in the Flat IGES file, and it will all be correctly positioned in
model space.
To help organize these files that have the potential of being very large, place
each instance of a part within an assembly into its own layer in Pro/ENGINEER
before exporting the assembly as IGES Flat. The layers will be transferred as
“levels” along with the assembly in the IGES file. The IGES levels are translated
into ALIAS Sets. This means that the members of one set are all of the surfaces
that comprise an instance of a part in the assembly.
The interface ID that was specified for each layer is the means by which Pro/
ENGINEER layer information is transferred via IGES. IGES does not support
names for layers. Layers in IGES are called “levels” and a level is identified by a
number, not a name. This is why Pro/ENGINEER asks you to assign a number
as well as a name to a created layer. The name is more useful within Pro/
ENGINEER, but the number is important for data transfer.
When the IGES file is imported into AliasStudio, the IGES level information is
created as AliasStudio Sets. To display the level information, go the Set Lister
(Pick > from lister > SETS). You will notice there exists sets whose names have
the format LEVEL#n, where n is the "interface id" that was specified in Pro/
ENGINEER.
One level
Outputs an assembly IGES file with external references pointing to the IGES files
of its components. This contains only top-level geometry.
All levels
With the All Levels option, Pro/ENGINEER outputs n+ 1 IGES files, assuming
that there are n parts or sub-assemblies in the assembly. There will be one IGES
file for each part or sub-assembly (for a total of n IGES files) and one master
IGES files that contains external references (IGES entity 416 form 1) to the ncomponent IGES files. Each external reference to a component IGES file within
the master IGES file is contained within an IGES Subfigure Definition (entity
308), which is instanced once by an IGES Subfigure Instance (entity 408). The
model of each component referenced by the master IGES file is in definition
space; that is, placed at the origin. Each component is transformed into model
space via the transformation contained in the Subfigure Instance (entity 408) in
the master IGES file.
If the n-component IGES files are individually imported into AliasStudio, the
resulting model will be incorrect, since each component will be placed at the
origin, rather than the correct spot in model space.
If the master IGES file is imported into AliasStudio, there will be no model at all!
This is because AliasStudio does not support the IGES External Reference (416
form 1) entity. This entity is generally frowned upon because it contains the
filename of the component IGES file, and filenames are generally not portable
between operating systems.
All parts
Outputs an assembly to IGES as multiple files containing geometry information of
its components and assembly features. These parts use the same reference
coordinate system to ease reassembly in the receiving system.
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Detailed file format information
PTC Granite format (Windows Only) (page 77)
STEP format (page 80)
IGES format (page 71)
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CATIA V4
AliasStudio CATV4 DirectConnect is a stand-alone utility that allows the
exchange of 3D model data between AliasStudio and CATIA using the CATIA/
AliasStudio neutral format CAI.
CATIA Requirements
●
Version 4.2n of CATIA
●

SurfaceStudio, AutoStudio, Studio or DesignStudio.

Use the following summarized list of modeling practices discussed in this section
as a quick reference guide if problems arise.
>
●

Before you create the model
Units should be set to mm.

In the Construction Settings window:
●

The Rational geometry flags should be toggled OFF.

Tolerances should be set as follows:
●

Curve Fit Distance =.01 mm (lower as necessary)

●

Curve Fit Checkpoints = 10

●

Max Gap Distance = .01 mm (this value should remain the same as Curve Fit
Distance)

●

Trim Curve Fit =.005 mm (lower as necessary)

>
●

While you create the model
Use degree 5 curves and surfaces to achieve curvature continuity between
surfaces.

●

Models should be transferred periodically from AliasStudio to CATIA during
construction to manage the quality of the model being created.

●

Periodically stitch the geometry once it is in CATIA to ensure that the model
meets all tolerance requirements.

●

Avoid using Object edit > Attach > Attach since this function creates
multiknots in AliasStudio geometry.

●

Avoid using Surfaces > Skin between trimmed surface boundaries, since
excessive amounts of data are created in the resulting surface. If Skin is
used between trim boundaries, the resulting surfaces should be checked for
multiknots before export.

●

Use surface building tools such as Surfaces > Boundary Surfaces >
Square and Surfaces > Swept surfaces > Rail surface to ensure and
control curvature continuity between surfaces.

Workflow
Before transferring geometry between AliasStudio and CATIA, you should
consider the purpose of the transfer to plan an appropriate workflow. Two
common workflows are:
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●

Geometry (describing mechanical components) is transferred from CATIA to
AliasStudio as reference data for concept design surfacing, then the
AliasStudio model is transferred back to CATIA.

●

A AliasStudio model is transferred to CATIA, and both AliasStudio and CATIA
databases are developed independently. Later, the modified AliasStudio
model is transferred again to CATIA, replacing the AliasStudio geometry from
the first transfer. In this scenario, all work done in CATIA on the original
AliasStudio model (ribs, thickness) will be applied to the new modified
AliasStudio model.

There are many variations on these two examples. Whatever the transfer
scenario, you should carefully plan the transfer process, to ensure that the
appropriate data is written out and is useful.
What happens when you replace AliasStudio geometry
A common workflow using AliasStudio and CATIA together is one where you
replace existing AliasStudio geometry in a CATIA model file with updated
AliasStudio geometry. This workflow allows you to continue working in
AliasStudio, modifying a model that has already been passed over to CATIA.
When you want to update the CATIA database with the completed changes, the
surfaces that have been modified are passed to CATIA. You import the new
AliasStudio geometry and then redefine the skin that includes the faces in
question using the Limit2 > Skin > Create/Modify tool.
If you want to make changes to a face or surface using AliasStudio and then
include that modified surface in the CATIA model, you only have to redefine the
skin to its members. That is, this time you leave out the original face and include
the new AliasStudio-modified face. This way AliasStudio geometry can be used
to modify CATIA models at any point throughout the development cycle.
What are the curve to fit distance tolerances in AliasStudio
The Curve Fit Distance is the tolerance to which trim boundaries are rebuilt to (or
approximated). The default positional tolerance in CATIA is .1 mm, and the
AliasStudio Curve Fit Distance setting should be set to 0.01mm.
This Curve Fit Distance setting should normally be accurate. If you find that it is
not resulting in AliasStudio geometry that can be successfully used in CATIA,
then experiment with the Curve Fit Distance—it can set to as low as 0.005 mm.
This setting will enhance the success of post transfer processes, such as
skinning, that are to be carried out once the geometry is in CATIA.

The Curve Fit Distance tolerance in AliasStudio should not be set at less
than 0.001 mm. Lower than this will impact processing time.

Whether you are creating a model, verifying a model, or debugging a translation,
there are a number of tools in AliasStudio you can use to check the quality of the
geometry you have created. The most useful tool is the Locators > Deviation
Min/max measurement tools. Use this tool to check the maximum distance
between any two surface boundaries.
Detailed file format information
CAI format for CATIA V4 files (page 82)
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CATIA V5
AliasStudio CATIA V5 DirectConnect is a stand-alone utility that allows the
exchange of 3D model data between AliasStudio and CATIA V5 using the native
CATIA part (.CATPart) and product (.CATProduct) files.
CATIA Requirements
●
Version 5 of CATIA (Release 6 to 16).
●

Version 2008 of an AliasStudio software product, and a CATIA V5
DirectConnect license.

●

Windows operating system.

See Before you create the model (page 21) for a list of modeling practices to use
as a quick reference guide if problems arise.
Before you create the model
Units should be set to mm.

●

Optimal tolerances should be set as follows, as recommended by Dassault
Systemes:
●

Curve Fit Distance = 0.001 mm (lower as necessary)

●

Curve Fit Checkpoints = 10

●

Max Gap Distance = 0.01 mm

●

Trim Curve Fit = 0.005 mm (lower as necessary)

●

Topology Distance = 0.02 mm

>
●

While you create the model
Models should be transferred periodically from AliasStudio to CATIA during
construction to manage the quality of the model being created.

●

The AliasStudio model should be capable of being successfully stitched
before export. If you periodically stitch the geometry to ensure that the model
meets all tolerance requirements, you’ll have a good indication of whether
the final model will stitch correctly.

●

Avoid using Object edit > Attach > Attach since this function creates
multiknots in AliasStudio geometry that may result in unusable geometry in
CATIA.

●

Use surface building tools such as Square and Rail Surface, taking
advantage of the Boundary Rebuild option to control curvature continuity
between surfaces and ensure surfaces do not contain multi-knots.

●

Use Evaluate > Check model to be alerted to potential problems: it’s
another good practice.

Workflow
Before transferring geometry between AliasStudio and CATIA, you should
consider the purpose of the transfer to plan an appropriate workflow. Two
common workflows are:
●

Geometry (describing mechanical components) is transferred from CATIA to
AliasStudio for concept design surfacing, then those Studio surfaces are
transferred back to CATIA.
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●

A AliasStudio model is transferred to CATIA, and both AliasStudio and CATIA
databases are developed independently. Later, the modified AliasStudio
model is transferred again to CATIA, replacing the AliasStudio geometry from
the first transfer. In this scenario, all work done in CATIA on the first
AliasStudio model transfer will affect the new, modified geometry.

There are many variations on these two examples. Whatever the transfer
scenario, you should carefully plan the transfer process, to ensure that the
appropriate data is written out and is useful.
What are the curve fit distance tolerances in AliasStudio
The Curve Fit Distance is the tolerance to which trim boundaries are rebuilt to (or
approximated). The default positional tolerance in CATIA V5 is 0.001 mm, and
the AliasStudio Curve Fit Distance setting should be set to 0.001mm.
This Curve Fit Distance setting should normally be accurate. If you find that it is
not resulting in AliasStudio geometry that can be successfully used in CATIA,
then experiment with the Curve Fit Distance—it can set to as low as 0.001 mm.
This setting will enhance the success of post transfer processes, such as
skinning, that are to be carried out once the geometry is in CATIA.

The Curve Fit Distance tolerance in AliasStudio should not be set at less
than 0.001 mm. Lower than this will impact processing time.

Whether you are creating a model, verifying a model, or debugging a translation,
there are a number of tools in AliasStudio you can use to check the quality of the
geometry you have created. The most useful tool is the Locators > Deviation
Min/max measurement tools. Use this tool to check the maximum distance
between any two surface boundaries.
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I-deas NX series
You can intergrate AliasStudio models into I-deas NX (UGS PLM solutions).
Often the workflow will require that the designer send geometry over to the
engineer using a CAD system. The CAD operator will then use the model to
describe a solid part and perform other engineering process such as describing
ribs, bosses and other mechanical details.
At any point the designer may need to update the information in the CAD system
by re-exporting changes made to the original model in AliasStudio so that those
changes can be integrated into the CAD database.
MasterSeries Requirements
●
I-deas NX 9, 10, or 11 series.
●

I-deas DirectConnect

●

An AliasStudio software product.

Use the following summarized list of modeling practices as a quick reference
guide to avoid data transfer problems.
>
●
●

Before you create the model
Units should be set to mm.
In the Construction Options window:
The Modeling Modes should be set to NURBS.
Tolerances should be set to the following values
◆

●

◆
◆
◆
◆

>
●

Curve Fit Distance = 0.005 mm
Maximum Gap Distance = 0.005 mm
Curve Fit Checkpoints = 10
Trim Curve Fit = 0.001 mm

While you create the model
Use degree 5 curves and surfaces to achieve curvature
between surfaces.

continuity

I-deas does not support degree 7 geometry. Geometry created in
AliasStudio which is degree 7 will be rebuilt to degree 3 (cubic) upon import
to I-DEAS. Adjacent AliasStudio surfaces which had been built with continuity
between them may no longer have that continuity after they are rebuilt in IDEAS.
●

Surfaces can be overbuilt and trimmed back before exporting. This will result
in a greater success rate when the surface geometry is offset in I-DEAS.

●

Models should be transferred periodically from AliasStudio to Master Series
during construction to manage the quality of the model being created.

●

Avoid using Surfaces > Skin and Object Edit > Patch between trimmed
surface boundaries since excessive amounts of data are created in the
resulting surface.

●

Use surface building tools such as Square and Rail Surface, taking
advantage of the Boundary Rebuild option to control curvature continuity
between surfaces and ensure surfaces do not contain multi-knots.
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Geometry types exported to I-deas
The following geometry types can be exported to I-deas using I-deas
DirectConnect:
●

Single CVs (points)

●

All curves (with or without attributes: lines, polylines, etc.)

●

Faces

●

Curves on Surface

●

Surfaces

●

Target Surfaces

●

Trimmed Surfaces

●

Trimmed Surfaces with multiple trim regions

●

Target Trimmed Surfaces

●

Shells

Polysets are the only geometry entities that are not supported by Master
Series.

Workflow
The workflow of transferring data into I-DEAS NX series requires that the
designer send geometry over to the engineer. The CAD operator will then use the
model to describe a solid part and perform other engineering process such as
describing ribs, bosses and other mechanical details.
At any point the designer may need to update the information in the CAD system
by re-exporting changes made to the original model in AliasStudio so that those
changes can be integrated into the CAD database.
>

Shell imported geometry

Shelling, or creating a topological description from AliasStudio models, is a
common workflow in AliasStudio and I-deas NX series. When exporting a model
from AliasStudio, you must ensure that the geometry is built to the correct
tolerance and that it can be stitched. The stitching process in AliasStudio
identifies gaps between surfaces so that you can repair the appropriate geometry
before exporting to I-deas NX series.
During stitching, the surfaces are twinned. This means that the surface
boundaries may be split to accommodate adjacent surfaces, and periodic
geometry is detached into multiple surfaces.
For this reason, you should save the AliasStudio wire file before stitching so that
if further modifications are required to be made to the AliasStudio model, the
construction history will be intact.

Stitched geometry saved to an AliasStudio wire file cannot be unstitched to
its original state.
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>

Export features from AliasStudio

The term part in I-deas NX series refers to geometry that has been saved out as
a part. The term feature refers to any attribute that augments the basic shape of a
part and distinguishes it from other parts that could be derived from the same
basic shape. More precisely, features are objects whose key dimensions and
orientations have been controlled, thus allowing you to control your design. You
can bring in parts or features to replace existing features on the workbench.
Since I-deas NX series creates each element of a model as a part or feature, it is
useful to import components of the AliasStudio model as individual AliasStudio
wire files that can be manipulated in I-deas NX series as individual features.
Major components of the AliasStudio model can be transferred separately so that
they can be used to construct individual features. The advantage of this
technique is that individual features can be “replaced” to give added flexibility.
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Unigraphics
AliasStudio Unigraphics DirectConnect is a stand-alone utility that allows the
exchange of 3D model data between AliasStudio and Unigraphics.
• See movie: unigraphics.rm
Unigraphics Requirements
In order to use Alias UG DirectConnect, the Unigraphics installation must
include one of the following licenced options:

●

Unigraphics NX Open API Execute or
Unigraphics NX Open Package Execute
You must have access to Unigraphics software for the same platform on
which you are running AliasStudio.
◆
◆

●

●

Unigraphics utilities supported now include versions 16-20, NX, and NX2 for
AlToUG and UGToAl.

●

An AliasStudio software product.

>
●

Before you create the model
Units should be set to mm.

In the Construction Settings window:
◆
The Rational geometry flag can be toggled OFF.
Tolerances should be set as follows:
◆
◆
◆

◆

>
●
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Curve Fit Distance = .01 mm (lower as necessary)
Curve Fit Checkpoints = 10
Max Gap Distance = .01 mm (this value should remain the same as
Curve Fit Distance)
Trim Curve Fit =.005 mm (lower as necessary)

While you create the model
Use degree 5 curves and surfaces to achieve curvature continuity between
surfaces and successful data transfer.

●

Models should be transferred periodically from AliasStudio to Unigraphics
during construction to manage the quality of the model being created.

●

The AliasStudio model should be successfully stitched before export, but you
should also periodically stitch the geometry to ensure that the model meets
all tolerance requirements.

●

Avoid using Object edit > Attach > Attach since this tool creates multiknots
in AliasStudio geometry.

●

Avoid using Surfaces > Skin between trimmed surface boundaries, since
excessive amounts of data are created in the resulting surface. If Skin is
used between trim boundaries, the resulting surfaces should be checked for
multiknots before export.

●

Use surface building tools such as Surfaces > Boundary Surfaces >
Square and Surfaces > Swept surfaces > Rail surface to ensure and
control curvature continuity between surfaces.

Workflow
Before transferring geometry between AliasStudio and Unigraphics, you should
consider the purpose of the transfer to plan an appropriate workflow.
Two common workflows are:
●

Geometry (describing mechanical components) is transferred from
Unigraphics to AliasStudio to be used as reference data for concept design
surfacing, then the AliasStudio surface model is transferred back to
Unigraphics.

●

A AliasStudio model is transferred to Unigraphics, and both AliasStudio and
Unigraphics Databases are developed independently. Later, the modified
AliasStudio model is transferred again to Unigraphics, replacing the
AliasStudio geometry from the first transfer. In this scenario, all work done in
Unigraphics on the first AliasStudio model transfer will affect the new,
modified geometry.

There are many variations on these two examples. Whatever the transfer
scenario, you should carefully plan the transfer process, to ensure that the
appropriate data is written out and is useful.
Detailed file format information
Unigraphics par and assembly format (page 73)
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Solid Imaging
Solid Imaging is a component of Rapid Prototyping which uses a database to
translate three-dimensional geometry into physical models or parts using a
variety of resins and other materials. The file formats used by AliasStudio to
output files for Rapid Prototyping are the STL and SLC.
Solid Imaging Requirements
NURBS surfaces must be translated into either the .stl or .slc format before
reading the file into the solid imaging machine software.
Workflow
AliasStudio wire files exist as NURBS data. To use that data to create physical
models using solid imaging technologies, you must translate the NURBS to either
the .stl or .slc format so that the geometry can be read by the solid imaging
machine’s software. Included in the list of solid imaging technologies is SLA
(Stereolithography), SLS (Selective Laser Sintering), LOM (Laminated Object
Manufacturing), SGC (Solid Ground Curing), FDM (Fused Deposition Modeling)
and others.
Converting the AliasStudio geometry to the .stl format or the .slc format can be
done from within AliasStudio.

Consult with the operator of the solid imaging machine to optimize the
transfer of data.

STL Format
An.stl file is a tessellated file (binary or ASCII), which means the NURBS surface
is described by a series of triangles. The resolution of this polygonized data base
is defined in AliasStudio by the subdivision characteristics of the original NURBS
surface. Once the tessellated geometry is sent to the Solid Imaging technology,
the geometry is sliced, and then those slices are used to describe the physical
model that will be produced.
With STL as the transfer format, you can send geometry to most Solid Imaging
technologies while controlling the resolution of the finished model.
The STL file exported from AliasStudio conforms to 3D systems file format
version 2.0. When you export a model as an STL file, AliasStudio displays:
●

A "solid check" is run-on the model and the results are displayed at the
prompt line. This tessellation check determines if it is a valid solid watertight
model or if it has any gaps indicating topological errors. This allows the
AliasStudio user to determine if the data being transferred can be used by
the operator of the solid imaging (for example SLA) machine to build the part.
If gaps are found, the user receives a warning indicating that it is an illegal
solid and the number of free edges in the model. When you view the model,
edges with gaps are highlighted in red so that you can easily identify where
gaps are and then repair the surface model.
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●

Stitch and tesselation tolerances options, allow you to set the merge vertices
tolerance, the maximum distance at which two vertices will be merged
together into one.

●

During tessellation, degenerate triangles (with two or more equal vertices)
are removed and the normals of the triangles are recalculated.

SLC format
An.slc file (StereoLithography Contour) cuts 2D contours of the 3D data base.
These contour lines are polylines. The advantage to using this file format is that
the NURBs geometry description in AliasStudio is directly sliced and therefore
fewer iterations are required between the original geometry and the data sent to
the Solid Imaging machine to be built.
>

SLC header information

The header section of the .slc file is an ASCII character string (up to 2048 bytes)
containing global information about the model.
The output in the header provides the following information:
●

SLC file format version number (-SLCVER2.0)

●

Output units (-UNITS<INCH/MM>

●

Type of model (-TYPE<PART/SUPPORT/WEB>)

●

Vendor package and version number (which produce the SLC file (PACKAGE ALIAS STUDIO V2008)

●

Calculations and sets from SLC output x,y,z extends of the model (EXTENTS mx,Mx,my,My, mz,Mz)

Header keywords (CHORDDEV, ARCRES, SURFTOL, GAPTOL,
MAXGAPFOUNS, EXTLWC, STHICK, STARD and ENDD) are set to 0.0.
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HOW

DO

I?
How to import and export data from WebDAV environments.
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Manage files through a WebDAV interface
WebDAV features in File operations, available on the Studio browser only.

Manage your digital assets in WebDAV
How to manage your files on a WebDAV server while working within the
AliasStudio environment.
Unlike local file storage, this function enables you to share and manage digital
assets in a group environment. For more information about WebDAV and
WebDAV standards, see http://www.webdav.org.
It allows you to:
●

Work in collaborative environments giving access to existing Asset
Management systems with WebDAV support.

●

Browse a WebDAV server from within the AliasStudio environment.

●

Access password protected directories on a WebDAV server.

●

Create, Copy, Move,Delete and drag and drop WebDAV resources from
within the AliasStudio environment.

●

Create and Rename directories and files from within the AliasStudio
environment.

●

Drag and Drop resources from a WebDAV server onto AliasStudio to open
the file.

●

Sort resources by File Type, Date modified, Size or Name.

●

Set up your proxy server workgroup for use from behind a firewall.

●

In order to use WebDAV functionality, you must use the AliasStudio browser
(set in Preferences > General Preferences, in the System section).

To browse a WebDAV server
From within the AliasStudio environment, browse resources on a WebDAV
server.
1

Choose Preferences > General Preferences, go to the System section, and
set Type of File Browser to AliasStudio.

The Windows browser does not support WebDAV servers.
2

Choose File > Open.

3

Type the URL location of your server
http:// WebDAV_server_name/

or, if in a secure environment
https://WebDAV__server_name/passwordProtected/
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Spaces in URLs are permitted in the AliasStudio browser.

To access a password protected directory
Use HTTP calls to access secure files and launch the security detection system
to scan a request from user's computer.
1

Locate the secure area on your WebDAV server.
https://WebDAV__server_name/passwordProtected/

2

Enter the required user authentication information.
User Name:
Password:

To copy a WebDAV resource
Download a resource to and from a WebDAV server to a client machine.
1

Highlight the file you wish to copy.

2

Choose File > Copy.

Authentication (for example, user name and password) must be the same on
the source and destination URLs.

To move a WebDAV resource
Drag and drop the copied file into the new directory. From within the AliasStudio
browser move files around in a WYSIWYG environment.
1

Highlight the file and choose File > Copy.

2

With the left mouse button held down drag the file to a new directory.

3

Release the mouse button. The file is moved.

Authentication (for example, user name and password) must be the same on
the source and destination URLs.

To delete a WebDAV resource
From within the AliasStudio environment learn how to delete a resource.
1

Highlight the file.

2

Choose File > Delete.

To drag and drop a WebDAV resource
Drag and Drop resources from a WebDAV server onto AliasStudio to open the
file.
1

Locate and hightlight the wire file you wish to work in AliasStudio

2

Drag and drop this file on AliasStudio which is already running on your
desktop.
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AliasStudio will then open that file.
To sort WebDAV resources
Sort files by file type, date modified, size and name.
1

Choose the directory you wish to sort and use the Sort pop-up menu.

2

Choose to sort your directory list by File Type, Date modified, Size or Name.

To save a file as a WebDAV resource
1

In AliasStudio, choose File > Save.

2

Type or browse to the directory to which you want to save the resource.

3

Double-check the name of the wire file and click Save.

To save a new file as a WebDAV resource
1

In AliasStudio, choose File > Save As.

2

Type or browse to the directory to which you want to save the resource.

3

Type a name for the wire file and click Save.

To save a WebDAV resource with another name
1

In AliasStudio, choose File > Save As.

2

Type or browse to the directory to which you want to save the resource.

3

Backspace or Delete the text in the Name field, type a new name for the wire
file and click Save.

To export a WebDAV resource to another file format
1

In AliasStudio, choose a submenu item from the File > Export menu.

2

Type or browse to the directory in which you want to save the resource.

3

Either delete and type a new name for the file, or use the existing file name,
and click Save.

To set up proxy servers for WebDAV
To access external servers which have different proxy settings.
Add proxy addresses, ports and exceptions listing internal servers to enable
access to servers.
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1

Select Preferences > General Preferences.

2

In the File System section, check Browser Web Proxy.
You may need to contact your system administrator for in formation to fill in
the following fields.

3

Type the Proxy Host Name of the proxy server your company uses to allow
users to browse outside their firewall.

4

Type the Proxy Port for this host name.

5

Type the Proxy Exceptions of internal servers used within your company.
Separate entries with a semicolon.

6

Select Save.
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Import CAD data files
How to import CAD data types into AliasStudio.

Import a data file
How to import a number of different file formats.
●

Use File > Import > File ❑
or

●

Use File > Open ❑
Choose the appropriate file format type.

Import DWG/DXF files
How to import the geometry of a DWG or DXF file.
●

Use File > Import > File
or

●

Use File > Open

The following types of DWG and DXF data are supported:
◆
◆
◆
◆
◆
◆
◆
◆
◆

lines, arcs, and splines
extruded curves
extrusions
layers
meshes
surfaces
text
3D solids
entity colors

Import Illustrator files
How to import the geometry of an Illustrator file.

Only up to Illustrator version 8 is supported.

To import an illustrator file
1

Choose File > Import > File and set the Illustrator options.
By setting Illustrator options, you can enable AliasStudio to import the
geometry as a Group of curves or as individual curves. You can also Scale
the image before importing it into AliasStudio.
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Open a Binary STL file
How to open a Binary STL file.
Choose File > Open to open a binary STL file. The STL file opens as a mesh in
AliasStudio.

The STL file is a unitless format. Set the units in Preferences >
Construction options before importing the file.

Import Cloud data
Learn how to import point cloud data from a file or directly from EvalViewer.
Some cloud data is available from your own scanner, the network, DAT tape, or CDROM. AliasStudio can import Cyberware point cloud files.
To import point clouds from storage
1

Choose File > Import > Cloud from the menus.
The file requester appears.

2

Type the path to the cloud point file you want to import.
or
Use the file list to browse through directories, then double-click the icon of
the point cloud file you want to import.

To import point clouds directly from EvalViewer
1

In EvalViewer, choose Edit > Copy from the menus.

2

Switch to AliasStudio, and choose Edit > Paste from the menus.

You may want to copy or link your scanner data directory to the relevant
directory inside the cloud directory of your project.

For example:
◆

To copy Cyberware data to your AliasStudio project directory from your
current working directory, type the following in a Unix Shell window:

cp * ~/user_data/projdir/cloud/cyberware/
◆

To link Steinbichler data on a CD-ROM into your AliasStudio project
directory, type the following:

mv ~/user_data/projdir/cloud/steinbichler ~/save.sb
ln -s /CDROM ~/user_data/projdir/cloud/steinbichler Options

Import a PTC Granite or a Pro/ENGINEER part file
How to import PTC Granite files or a Pro/ENGINEER part file.
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When importing geometry from Pro/ENGINEER to AliasStudio, you should:
●

Use menu File > Open to read the Pro/ENGINEER part file (.prt) or the
Granite file (.g). The translator will be automatically launched.

●

Review the File > Open PTC Granite

import options.

Import from Pro/ENGINEER into AliasStudio via Pro/RENDER
How to import Pro/ENGINEER render format files.
To convert Pro/ENGINEER Render format files into AliasStudio
wire files.
1

Open a Unix shell.

2

Type utility the help command:

PRenderToAlias -h
3

Choose from the following options to write your command.

PRenderToAlias
Arguments: [<options>] [<infile> [<outfile>]]
Options:
-s
scale Input scale factor (for example. -s2.0)
-u
Input units. Acceptable values are
MI,FT,IN,MIL,UIN,KM,M,CM,MM,UM]. The default is
-uIN
-g
Group the geometry
-n
Do not merge vertices
-r
Recalculate vertex normals
-p
Merge vertices according to xyz position only
-t pos_tol
Specify merge vertices position tolerance value in input units.
The default is 0.0001.
-a nrm_tol.
Specify merge vertices normal tolerance value in degrees. The
default is 1 degree.
Where:
<infile> is a Pro/ENGINEER Render file. If it is absent, input
comes from stdin.
<outfile> is an Alias wire file. If it is absent, output goes to
stdout.
By default all vertices are merged according to their positions and
normals.
>

Examples

PRenderToAlias crankshaft.slp crankshaft.wire
PRenderToAlias -g -t0.001 hammer.slp hammer.wire
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Pro/ENGINEER options for export and import of STEP or IGES files
To make the import and export of IGES and STEP files easier for AliasStudio to read.
1

In Pro/ENGINEER, select Utilities > Options

2

Add the following data to the configuration file.

IGES_OUT_ALL_SRFS_AS 128
IGES_OUT_SPL_CRVS_AS_126 YES
IGES_OUT_SPL_SRFS_AS_128 YES
IGES_OUT_MIL_D_28000 NO
IGES_OUT_TRM_SRFS_AS_143 NO
IGES_OUT_TRIM_CURVE_DEVIATION DEFAULT
INTF_OUT_BLANKED_ENTITIES NO
INTF3D_OUT_EXTEND_SURFACE YES
INTF3D_OUT_FORCE_SURF_NORMALS YES
IGES_IN_106_F2_AS_SPLINE NO
IGES_IN_DWG_LINE_FONT YES
IGES_IN_DWG_PNT_ENT YES
IGES_IN_DWG_COLOR YES
FIX_BOUNDARIES_ON_IMPORT YES

Import CATIA V4 into AliasStudio
How to import a CATIA V4 file and review the mapping process used for
geometry types and non-geometric data.
1

Choose File > Import > File ❒to display the basic file format options.

2

Choose File format CATIA V4

What happens on import of a CATIA file into AliasStudio?
The model’s surface geometry is converted in AliasStudio into a skin by joining
surfaces and trimmed surfaces or faces. The skin can then be used for a variety
of downstream processes in CATIA.

If the AliasStudio geometry is exported as a AliasStudio shell, CATIA
automatically creates a skin from it. In other words, the successfully
imported CATIA geometry is made up of surfaces and faces, as well as a
CATIA skin. This significantly reduces the amount of time the CATIA operator
must spend preprocessing the AliasStudio model to be used in CATIA.

Import a CATIA V5 file into AliasStudio
To open a CATIA V5 file, choose File > Open from within AliasStudio.
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You can open either part (.CATPart) or product (.CATProduct) documents in
AliasStudio simply by clicking on the file name in the file browser.
If you get “File not recognized” errors on your CATIA part file, you can either use
drag or drop with Studio or use the stand-alone utility to convert the file.
One option is available for importing CATIA V5 document files:
Auto Stitch
Click this option on to convert a CATIA V5 solid body or sheet body to a shell
in AliasStudio; if this option is off, a grouped set of trimmed surfaces are
created instead.
The following CATIA V5 entities are brought into AliasStudio:
CATIA V5 entity

brought into AliasStudio as

Curves

NURBS curve of appropriate degree.

SplineCurve
Circle
Ellipse
Conic
Hyperbola
Parabola
Line
IntCurve
BsplineCurve
HelixCurve
PLine
PSpline
PCircle
PEllipse
PParabola
PHyperbola
PNurbs
Surfaces

NURBS surfaces of appropriate
degree

Products

Groups and instanced groups.
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CATIA V5 entity

brought into AliasStudio as

Solids

Set of faces that have shared edges at
the boundaries where the faces meet
within tolerance. Brought in as NURBS
surfaces. Closed shell surfaces are
stiched in a shell (if Auto Stitch is ON);
otherwise, a group of trimmed surfaces
is created.

Color RGB, Layer,
Show (Visibility)

Shader Color RGB, Layer, Visibility.

Layer

By default, Layer. Caution: no names
are used, just layer numbers.

Point

SpacePoint.

Unbounded plane

Planar surface.

Surface Patch

NURBS Surface of appropriate degree

Surfaces
Plane
NurbsSurface
Cylinder
Sphere
Torus
Cone
FilletSurface
ChamferSurface
DraftSurface
OffsetSurface
SweepSurface
GenericFillet
GenericRuledSurface
Tabulated Cylinder
RevolutionSurface
BsplineSurface
CircularSweep
RuledSurface
Invisible entities
Noshow

42

Invisible entities, unless the option -v is
used when importing the file.

Import a Unigraphics file into AliasStudio
How to import Unigraphics files.
1

Choose File > Import > File ❒

2

Choose Unigraphics file format options.

>

What happens on import of a Unigraphics file into AliasStudio?

When importing a Unigraphics file into AliasStudio watch out for the following:
●

You must have access to Unigraphics software for the same platform on
which you are running AliasStudio.

●

AliasStudio supports Unigraphics NX 2.0, 3.0 and 4.0.
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Export CAD data files
How to export CAD data types from AliasStudio.

Export a data file
How to export a number of different file formats.
To export a file
●

Use File > Export > Active as ❒
or

●

Use File > Save as ❒
Choose the appropriate file format type.

Add a description to an export file
How to attach a comment to your export file.
To include a comment to your file
1

Choose Include Comments from the Save Options window.

2

Choose Edit File Comments, a shell will be displayed in which you can create
or update the comment.
There are no limits to the number of characters per comment line because
Edit Comment uses a user-defined editor.
The file comment that is exported from AliasStudio will be altered to conform
to these restrictions. That is, lines over 70 characters in length will be
wrapped, and the comment will be truncated at 500 lines.

Check for gaps before exporting to a solid model
How to stitch the surfaces before exporting your model to a wire file and replace
surfaces in I-DEAS MasterSeries.
To check stitching of surfaces
1

Stitch the surfaces using Surface Edit > Stitch > Shell stitch (with Keep
Originals on) and carry out a visual check to confirm there are no gaps. If the
model that has been stitched is intended to describe a closed volume, check
the stitched geometries using Object edit > Query edit.

2

Delete the shell and repair the NURBS model.

3

If required, stitch the surfaces again and export the stitched object to a wire
file. Also, save the NURBS model for further modeling operations.
For more information see Edges do not match (page 57).
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Export a DWG or DXF file
How to export a DWG or DXF file from AliasStudio
To save a DWG or DXF file
1

Choose File > Export > Active as ❑
or

2

File > Save as ❑

3

From the File Formats menu, choose DWG or DXF.
You are presented with two options:

Want curves
If this option is ON, the curves are exported, otherwise they are ignored.
Split surface at internal discontinuity
If Split Surfaces at internal discontinuities is ON and a surface has G1
discontinuities, it will be divided at each G1 discontinuity break.
4

Set the options as desired, and click Save

Export an Illustrator file
How to export an Illustrator file from AliasStudio.

Only up to Illustrator version 8 is supported.

To save an Illustrator file
1
2
3

Choose File > Print setup.
Set Output to File.
Set Output Style to Illustrator.
The output transfers the paint and shapes information. The results of opening
this file in Illustrator is a display of two objects:

●

an image plane (rendered image).

●

the shapes of the model which can be individually selected and manipulated.

4

Close the Print Setup window and print the file.

Use the tolerances required by a specific CAD package
How to use tolerance presets.
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Use Preferences > Construction options to set the tolerances enforced by the
modeling tools. The requirements for transfer to specific CAD packages are
available as presets.
To set up tolerances for transfer to a specific CAD package
1

Choose Preferences > Construction options.

2

Open the Construction Presets section.

3

Choose one of the settings profiles from the list:

●

Click the CAD software you want to model for. This sets the construction
options to values needed for maximum compatibility with that CAD package.

●

Click General CAD Settings if the CAD package that you want to model for is
not on the list. This sets the construction options to generic CAD values that
will be compatible with most CAD packages.

●

Click User Defined to set the construction options manually.

You cannot edit the presets of the CAD packages in the list directly. Choose
the name of the CAD package and click Copy to create a new profile you can
edit.

To create a set of custom tolerance setting
1

Open the Construction Presets section of the Construction Options window.

2

Choose one of the settings profiles from the list:
If the settings you want to add are very similar to one of the preset CAD
packages, click the name of the CAD
package.
Otherwise, click User Defined.

3

Click Copy.

4

Double click the new profile to rename it.

Export STEP/IGES/PTC Granite to Pro/ENGINEER
AliasStudio surface models can be transferred to Pro/ENGINEER in either IGES,
STEP or PTC Granite formats.
By using AliasStudio, there are two types of model information that can be set to
and read by Pro/ENGINEER: geometry information and topological information.
The AliasStudio IGES file includes only the description of the geometry
information. The STEP entities that AliasStudio supports means that both the
geometry information as well as the topology information can be transferred and
read into Pro/ENGINEER. The geometric data describes the basic shape of the
object and in both AliasStudio and Pro/ENGINEER, geometric data is
represented using NURBS.
Topological data describes how the geometric components are connected
together to form a solid. The STEP file format has advantages over IGES when
transferring AliasStudio models to Pro/ENGINEER because there is more
information describing the model that is being transferred.

47

Workflow for exporting PTC Granite files
When exporting PTC Granite geometry from AliasStudio to Pro/ENGINEER, you
should:
●

Set Preferences > Construction options Construction Presets to Pro/
ENGINEER before creating a model in AliasStudio for Pro/ENGINEER.

●

Use AliasStudio, choose File > Save as, with File Format Option set to PTC
Granite, to save a model,
or
Use AliasStudio, choose File > Export- > Active as, with File Format Option
set to PTC Granite, to save selected parts of the model.

●

Make sure the units system's settings in both Pro/ENGINEER and
AliasStudio are set to millimeters as the default.

●

Make sure the model part files do not have short edges (shorter than curve-fit
tolerance) before importing the PTC Granite file into Pro/ENGINEER. To
check, use Evaluate > Check model and select the option Model
Parameters > short edges.

●

Try to remove all surface multi-knots from your AliasStudio model before
saving as a PTC Granite file. Multi-knot PTC Granite files may not be read
into Pro/ENGINEER with proper trimmed edges.

●

Save translation time and make the transfer to PTC Granite format faster by
splitting closed surfaces, such as cylinder, torus, sphere and cone, into two
or four parts before saving. The Pro/ENGINEER translator will split closed
surfaces automatically but if this procedure is done before it will save time.

To create a PTC Granite file for Pro/ENGINEER
1

Choose Surface Edit > Stitch > Shell stitch to ensure you have created a
closed volume before exporting it in PTC Granite format.

2

Choose the object to be exported so that it is the “active” object.

3

Choose File > Export > Active as.

4

Choose PTC Granite from the File Format pop-down menu.

5

Choose the Save icon and specify the PTC Granite file name. AliasStudio
automatically appends the .g extension to the file name. This file is now
ready to be read into Pro/ENGINEER.
For more information refer to Workflow (page 19).

To export PTC Granite files
1

Choose the object to be exported so that it is the "active" object.

2

From the File menu, choose File > Export > Active as.

3

Choose PTC Granite from the Basic Save Options File Format pop-down
menu.

To create an IGES format file for Pro/ENGINEER
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1

Pick the object to be exported so that it is the "active" object.

2

Choose File > Export > Active as.

3

Choose IGES from the File Format pop-down menu.

4

Choose pro_engineer from the IGES by Vendor browser.
The configuration of the output variables for
Pro/ENGINEER have been determined through data exchange testing to
provide the best conditions for the creation of a solid model within Pro/
ENGINEER. You can alter the output variables to achieve different results.

5

Choose the Save icon and specify the IGES file name. AliasStudio
automatically appends the .igs extension to the file name.
The file is now ready to be read into Pro/ENGINEER.

To create a STEP file in AliasStudio for Pro/ENGINEER
Follow these steps to create a STEP format file for Pro/ENGINEER:
1

Select the object to be exported so that it is the “active” object.

2

From the File menu, choose File > Export > Active as.

3

Choose STEP from the File Format pop-down menu.

4

Choose AP214 from the Application Protocol.

5

The AliasStudio model should have already been stitched into a solid shell
(volume) or a shell (group of stitched surfaces that do not describe a volume.

6

Choose under the Model Type either:
Manifold Shells- A collection of stitched surfaces that do not describe a

volume is saved out as a G3 Manifold Shell.
or
Brep Solids-Stitched geometry that describes a closed volume is written out

as a G5 Brep Solid.
7

Choose the Save icon and specify the STEP file name. AliasStudio
automatically appends the .stp extension to the file name. This file is now
ready to be read into
Pro/ENGINEER.

To set options in Pro/ENGINEER for export and import

To make the import and export of IGES and STEP files easier for AliasStudio to read.
1

In Pro/ENGINEER, select Utilities > Options

2

Add the following data to the configuration file.

IGES_OUT_ALL_SRFS_AS 128
IGES_OUT_SPL_CRVS_AS_126 YES
IGES_OUT_SPL_SRFS_AS_128 YES
IGES_OUT_MIL_D_28000 NO
IGES_OUT_TRM_SRFS_AS_143 NO
IGES_OUT_TRIM_CURVE_DEVIATION DEFAULT
INTF_OUT_BLANKED_ENTITIES NO
INTF3D_OUT_EXTEND_SURFACE YES
INTF3D_OUT_FORCE_SURF_NORMALS YES
IGES_IN_106_F2_AS_SPLINE NO
IGES_IN_DWG_LINE_FONT YES
IGES_IN_DWG_PNT_ENT YES
IGES_IN_DWG_COLOR YES
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FIX_BOUNDARIES_ON_IMPORT YES

Export STL files
How to create a solid model for STL export and save it in an STL file.
To export a model to STL format, it must be either a mesh object, or a stitched
shell.
See Meshes on page 666.
See Repair defects in meshes on page 1037.
To stitch your model
1

Stitch the AliasStudio model to create a closed volume shell before exporting
an.stl file. Use Surface Edit > Stitch > Shell stitch with Keep Originals
on.

For best results in creating an .stl file, ensure that the geometry is stitched to
create a closed volume. Gaps in the shell are indicated by yellow lines in the
geometry window. Using an open shell to create an .stl file is not recommended.
To check for a closed volume
1

Choose Object edit > Query edit and use the right mouse button to display
the status of the shell. If the Closed Volume is True, the geometry can be used
to create an STL file.

To export shells in STL files
1

Choose File > Export > STL ❒

2

Select a shell object.

3

Press the Accept button.
A solid volume check is run. If the shell is not a closed volume (solid), the
prompt line indicates the number of boundaries found. In the geometry
window, the model displays red arrows pointing to the boundaries so you can
quickly identify where the problems are. Exit the tool if you need to repair the
surface model.

4

Adjust the Tolerance value in the option box.
The tolerance controls the number of triangles on the tessellated shell. It
describes the maximum difference (in current units) between the original
shell and the tessellated shell output to the STL file. The lower the tolerance
value, the greater the number of triangles. The tolerance value will be
reflected in the resolution of the physical model produced by the solid
imaging technology.

5

Press the Accept button.
The shell is tessellated, and displayed using the current mesh transparency
setting. Tests are run on the mesh to ensure that the triangles are not
degenerate and have consistent orientation, and that the mesh is manifold.
Repairs are made if necessary. Any boundaries will be drawn in red and
indicated by red arrows.
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You can modify the tolerance value in the option box and the tessellation will
be recalculated automatically.

If you still see red arrows, you may need to exit the tool and repair your
model manually.
6

Press the Accept button.
The Export STL browser is displayed.

7

Choose a name for the file and press Export STL.
The file is saved in STL format.

To export meshes in STL files
1

Select one or more mesh objects.

2

Choose File > Export > STL.
The Accept button appears in the lower right corner.

3

Press Accept.
The Export STL browser is displayed.

4

Choose a name for the file and click Save. Only the selected meshes are
saved.

STL files do not store units. AliasStudio always stores STL files in the current
units.
When AliasStudio reads STL files, it assumes they are in the current units. If
the units have changed, or if you are importing an STL file into another
application, the geometry may need to be scaled.

Export SDL files
To save out a Scene Description Language (SDL) file.
To export an SDL file
1

Choose File > Export > SDL.
The File Requestor appears.

2

Type the full path and file name for the SDL file in the File Requestor, or click
Show List and select the file using the
File Lister. If you select a file using
the File Lister, the SDL file will overwrite that file.

3

Click Save SDL.
To cancel the process, press Esc.

When exporting a SDL file
Delete all non-referenced shaders before exporting an SDL file, because all
shaders, whether they are actually assigned to surfaces or not, are written
out to the SDL file.

●

51

●

When you export an SDL file, each perspective window will generate an
image (or series of images) when the SDL file is rendered, because each
perspective window has an associated camera.
The file name you use for the SDL file is also used within the SDL file to
specify the output image file name. For example, if the SDL file is named
Planet, then the camera section of the SDL file will contain:
pix = "pix/Planet",
If there is a second perspective camera named camera2, the SDL file will
also contain:
pix ="pix/Planet_camera2",
If you have more than one perspective window, but only want to render an
image (or series of images) from one of them, either edit the SDL file, or pick
all objects, lights, and only one camera, and then choose File > Export >
Active as, and use that file to export an SDL file from.

●

By default, comments are not included in the SDL file. If you want comments
included, put the following line in your shell before starting AliasStudio:
setenv ALIAS_SDL_LONGFORM 1

To edit an SDL file
To edit an SDL file, you must first convert it to ASCII format (text), using the
AliasStudio Binary SDL command-line utility (bsdl). This utility allows you to
extract the text component from a binary SDL file, and replace the text
component in a binary SDL file. This is useful if you need to hand-edit an SDL
file.
SDL files now contain a binary component for large mesh files, because writing
the data out as text would increase the size of the SDL file to an extent that
parsing time by the renderer would also increase by a very large amount.
>

bsdl usage:
bsdl extract [-f] <text> <binary>

Extract ASCII SDL to <text> from a binary SDL file called <binary>. The file
<text> will not be overwritten unless the option -f is specified.
Any text editor can then be used to edit the <text> ASCII SDL file.
bsdl replace <text> <binary>
Insert the ASCII SDL file <text> into the binary SDL file <binary>, replacing the
ASCII SDL data.
For more information on the formatting of SDL files, see SDL.html on the
Technical reference page.

Export to CATIA V4
How to write out to the CATIA V4 file format.
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Workflow
Create a ‘skin’ and ’offsetting’ to create solid geometry from imported AliasStudio
models.

Stitched geometry saved to a AliasStudio wire file cannot be unstitched to its
original state.
1

Stitch the surfaces to perform a visual check to confirm there are no gaps.

2

Undo the stitch operation.

3

Save the AliasStudio wire file.

4

Stitch the surfaces again.

5

Export the stitched object to a CAI file.

Geometry not stitched prior to export from AliasStudio will not automatically
create a skin upon import into CATIA.

Review the summary of modeling practices as a quick reference
guide if problems arise. See CATIA Requirements (page 19)

Export to CATIA V5
Choose File > Save As ❑. In the Save As option window, choose CATIA V5 from
the list of file formats.
The following Studio entities are saved into CATIA V5:
Studio entity

saved to CATIA V5 format as

Curve (created
with either CVs
or Edit Points)

NURBS Curve of appropriate degree

Line

Line

Arc

NURBSCurve

Circular

RationalNURBSCurve. Note that
periodic objects will be divided into two.

Blend curves

NURBSCurve of appropriate degree.

Multiknot curve

NURBSCurve

Curve on
surface

NURBSCurve

Surface

NURBSSurface.

Surface Revolve NURBSSurface. Periodic objects will be
divided into two.
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Studio entity

saved to CATIA V5 format as

Multiknot
Surface

Surfaces divided in multiple surfaces if -d
option is used.

Shell

Solid. Caution: Alias closed shell
becomes a CATIA Solid. If -s option is
specified, the shell’s faces will become
surfaces.

sphere, cone,
cube, etc.

NURBSSurface. Periodic objects are
divided into two.

Rational sphere, NURBSSurface. Periodic objects are
cone, etc.
divided into two.
Shell

CATIA solid body, if shell is closed, or
Skin (open shell) if shell is open.

Surface with
Multiple trimmed surfaces
multiple disjoint
trimmed regions
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Closed periodic
curve

Periodic curves are divided into two
curves.

Shader Color
RGB

Color RGB

Layer

Layer (numbered). Layer name is
ignored.

Invisible

Invisible (no show)

Construction
vector

Line

Construction
plane

Plane

Symmetry

Converted if -b option for layer symmetry
is ON.

Space point,
Curve point,
Surface point,
Curve-onsurface point

Point

TROUBLESHOOT
How to interpret data transfer log files.
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Overview
Log files contains information on entity mappings, entity counts and the errors
and warnings given when transferring data. Use these files as tools to assist in
troubleshooting the data transfer.
●

Translation log files are produced during both import and export procedures.

●

Translation log files are saved in the same directory as your model file.

●

Translation log files contain entity mappings, entity counts, error and warning
messages and other helpful information.

AliasStudio provides utilities which are also useful in troubleshooting. For more
details please refer to our Utilities online manual.
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Edges do not match
All surface edges must be topologically matched before the geometry meets the
requirements of topologically described geometry in a CAD system.
Edges fail to match because of a mismatch in the topology of two or more
adjacent faces, or because the maximum distance between two adjacent edges
is greater than the current accuracy defined in the CAD system. There may be a
gap existing between the adjacent surface edges, or the edges may overlap to
the extent that they can not be stitched.
●

You can fix this problem by lowering tolerances in AliasStudio and recreating
the AliasStudio geometry before re-importing the file into the CAD system.
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View and interpret data transfer log files
Open a log file and interpret the data. Review this data to resolve problems in
data transfer.

Log file names
Learn the default file naming convention used in generating data transfer log
files.
In most cases translators automatically create log files using a user-defined
filename with a default filename extension. When storing format files the default
file name extensions are as follows:
For IGES
Import translation
.alias2iges (filename.alias2iges)
Export translation
.iges2alias (filename.iges2alias)
For VDAIS
Import translation
.alias2vdais (filename.alias2vdais)
Export translation
.vdais2alias (filename.vdais2alias)
For C4
Import translation
.alias2c4x (filename.alias2c4x)
Export translation
.c4x2alias

(filename .c4x2alias )

For Unigraphics
Import translation
.alias2unigraphics (filename .alias2unigraphics)
Export translation
.unigraphics2alias (filename .unigraphics2alias)
For JAMA-IS
Import translation
.alias2jamais (filename.alias2jamais)
Export translation
.jamais2alias (filename .jamais2alias)
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For Granite
Import translation
.alias2granite

(filename .alias2granite )

Export translation
.granite2alias(filename .granite2alias)
For STEP
Import translation
.alias2step (filename.alias2step)
Export translation
.step2alias (filename step2alias)
For CAI
Import translation
.alias2catia (filename.alias2catia)
Export translation
.catia2alias (filename .catia2alias)
For TC VisProducts
Import translation
.alias2jt (filename.alias2jt)
Export translation
.jt2alias (filename.jt2alias)

View STEP log files
How to view log files.
To view log files
1

Choose Utilities > Errlog to view these messages.
When retrieval is finished without errors, the following message is displayed:
STEP files retrieved successfully.
If there are errors in the retrieval, this message is displayed:
Problem Reading Step File, refer to log file and/or errlog
for details.
The AliasStudio errlog file and STEP logfile contain a specific error message
for each problem entity that is encountered, along with the entity’s STEP ID
and type.

Interpret CATIA log files
How to interpret a translation log file.
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Translation log file
The translation log file is produced during both import and export of CATIA files.
This log file contains entity mappings, entity counts, and Information, Error, and
Warning messages.
>

Interpreting the import log file

On import of a CATIA file, a translation log file is created in the same directory as
the CATIA file. The file name of the log file is the same as that of the CATIA file
with the extension.catia2alias added to it.
>

Log file

The log file contains:
●

a translation summary,

●

the time of translation,

●

conversion statistics, and

●

translation time.

If an error or problem occurs while processing an entity, the CATIA entity’s type
name, user identifier name, and instance name are printed, followed by the error
or warning message.
>

Extended log file

If you have chosen to have an extended log file produced, then the log file will
contain the same information as the log file, with the addition of:
●

CATIA entity name to Alias entity name mapping

●

CATIA entity type to Alias entity type mapping

Interpreting the export log file
On export of a CATIA file, a translation log file is created in the same directory as
the CATIA file. The file name of the log file is the same as the CATIA file with the
extension .alias2catia added to it.
>

Log file

If you have chosen to have a log file via the interface options, the log file will
contain:
●

a translation summary,

●

the time of translation,

●

conversion statistics, and

●

translation time.

>

Extended log file

If you have chosen to have an extended log file produced, then the extended log
file will contain the same information as the log file with the addition of:
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●

product/part contents, and

●

translation time.

Viewing IGES log files
IGES stands for Initial Graphics Exchange Specification. IGES was the first
attempt to make a "neutral file format". This enables different systems to transfer
data without the need of a specific translator for each system.
The first section of an IGES file typically describes the contents of a file. Each line
of this section is displayed on the information line.
If there is more than one line in the section, you can browse the contents of the
section after file retrieval is complete by using the prompt history window, or by
viewing the comments section of the IGES logfile created by the retrieve process.
Open a IGES log file
1

Choose File

> Show image

The AliasStudio errlog file and IGES logfile contain a specific error message
for each problem encountered.
Each error message includes the IGES entity type number and a Directory
Section line number where the entity occurs. The errlog file is located at /
usr/a1demo/errlog; you can browse it with any UNIX text editor (for
example, vi or jot). The IGES logfile is located in the same directory as the
retrieved IGES file.
>
●

Summary of messages in the IGES logfile
IGES file retrieved successfully
Indicates retrieval is finished.

Identifying IGES supported entities in log files
Learn more about the IGES entities supported on import by AliasStudio.
All other entities with an entity use flag value (Definition) are ignored by the input
translator.
Type

Form

IGES Entity

AliasStudio Entity

100

0

circular arc

B-spline curve

102

0

composite curve

B-spline curves
(group)

104

0-3

conic arc

B-spline curve

106

1

copious data

B-spline curve

106

2

copious data

polyline

106

11

copious data

polyline

106

12

copious data

polyline

106

63

closed area

polygon of polyset

61

108*

0*

plane

B-spline surface,
plane

110

0

line

line

112

0

parametric curve

B-spline curve

114

0

parametric surface

B-spline surface

116

0

point

control vertex

118

0-1

ruled surface

B-spline surface

120

0

surface of revolution

B-spline surface

122

0

tabulated cylinder

B-spline surface

124

0

transformation matrix

126

0-5

rational B-spline curve

128

0-9

rational B-spline surface B-spline surface

130

0

offset curve

B-spline curve

140

0

offset surface

B-spline surface

141

0

boundary entity

trim curve

142

0

curve on surface

trim curve

143

0

bounded surface

trimmed surface

144

0

trimmed surface

trimmed surface

308

0

subfigure definition

instance geometry

402

7,16

associativity instance

group

408

0

singular subfigure
instance

instance geometry

B-spline curve

IGES levels
All supported geometric IGES entities that are associated with IGES level <n>
are added to an Alias layer. For example, if a 126 B-spline entity’s directory entry
indicates that it is on level 42, then it is added to AliasStudio as Layer 42.
>

IGES ASCII format

The IGES translator imports ASCII format IGES files with or without linefeed
characters at the end of each record. Binary IGES files are not supported.

Unigraphics log files
Translation log file
The translation log file is produced during both import and export of Unigraphics
part files. This log file contains Entity Mappings, Entity Counts, and Information,
Error, and Warning messages.
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>

How to interpret an import log file

On import of a Unigraphics part file, a translation log file is created in the same
directory as the Unigraphics part file. The file name of the log file is the same as
that of the Unigraphics part file with the extension .unigraphics2alias added to it.
>

Short log file

If you have chosen to use a short log file via the interface options, the log file will
contain:
●

the pathname of the imported Unigraphics part file and the name of the
current AliasStudio stage into which the Unigraphics part file is being
imported.

●

the contents of the Unigraphics part file. This is a table that documents the
number of each type of Unigraphics entity in the file. This table includes all
entities in the Unigraphics part file.

●

any information, warning, or error messages that may occur during the
translation.

If an error or problem occurs while processing an entity, the Unigraphics’ entity’s
type name, user identifier name, and instance name are printed, followed by the
error or warning message.
>

Extended log file

If you have chosen to have an extended log file produced, then the log file will
contain the same information as the short log file, with the addition of:
●

the Detailed Entity Mapping Report. This report contains a mapping description
line for each entity processed.

The mapping description line in an extended import log file contains:
●

the Unigraphics entity type name (e.g. BsplineSurface)

●

the Unigraphics entity’s user id (e.g. WHEEL, or <NONE> if the entity does
not have a name)

●
●

●
●

>

the Unigraphics entity instance identifier
the string converted to, indicating that the following information pertains to the
Alias entity
the Alias entity type name (e.g. Trimmed Surface)
the Alias node name (e.g. WHEEL or node#50 in the case of a Unigraphics
entity name of <NONE>).
Interpret a export log file

On export of a Unigraphics file, a translation log file is created in the same
directory as the Unigraphics file. The file name of the log file is the same as the
Unigraphics file with the extension .alias2unigraphics added to it.
>

Short log file

If you have chosen to have a short log file via the interface options, the log file will
contain:
●

the name of the current AliasStudio stage from which the model was
exported (or the name of the AliasStudio Wire file if the command line
interface was used) and the pathname of the exported Unigraphics file
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●

any Information, Warning, or Error messages that may occur during the
translation

●

a table that documents the number of each type of Alias entity converted or
not converted to a Unigraphics entity.

If an error or problem occurs while processing an entity, the Alias entity’s type
name and node name are printed, followed by the error or warning message.
>

Extended log file

If you have chosen to have an extended log file produced, then the log file will
contain the same information as the short log file with the addition of:
●

>

the Detailed Entity Mapping Report which contains a mapping description line
for each entity processed.
Interpret a Unigraphics translation log

If the log file identifies an error during translation between AliasStudio and
Unigraphics in either direction, you can trace the information in the error
message back to the problem geometry. In some cases once the piece of
geometry has been isolated, the nature of the problem will be visually obvious
and you will need only to delete or manually fix the surface in question.
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Evaluation tools
There are a number of useful tools to help you to complete a successful data
transfer.
●

Evaluate > Check model

●

Evaluate > Continuity > Surface continuity

●

Evaluate > Surface Evaluate > Highlights

●

Evaluate > Surface Evaluate > Curvature

●

Evaluate > Surface Evaluate > Contour

●

Evaluate > Surface Evaluate > Horizon

●

Locators > Curve curvature

●

Locators > Deviation > Closest Point

●

Locators > Deviation > MinMax Curve-Curve deviation (Min/Max CrvCrv
deviation, Min/Max SrfSrf deviation, Min/Max CrvSrf deviation, Min/Max
cloud >Deviation > Deviation)

●

Surface Edit > Stitch > Shell stitch

●

Surface Edit > Stitch > Shell unstitch
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TIPS

AND

TRICKS
This section contains a list of tips related to the AliasStudio data transfer
workflows that will ease some tasks and increase your efficiency.

Stitching surfaces often improves data export through IGES, STEP and STL/SLC.
Save the original model before stitching.
Set up your units and tolerances at the beginning of your modeling session and save them
as a preset in Preferences > Construction Options. The next time AliasStudio is opened,
those presets will be in effect.

In Preferences > Construction Options, you cannot edit the presets of the CAD packages
in the list directly. Select the name of the CAD package and click Copy to create a new
profile you can edit.
Do not set the Curve Fit Distance tolerance in AliasStudio to a value smaller than 0.001
mm. A lower value will impact processing time.
The Maximum Gap Distance is the value that is used to check if the adjacent boundaries
are built closely enough to each other. It should never be smaller than the Curve Fit
Distance.
If you want to change the geometry of the AliasStudio model in Illustrator, export the model
as a Post Script file from AliasStudio. Open this file in Illustrator to manipulate the polygons.
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APPENDIX
Review background information on each file formats.

Details on File Format types
The following information provides some insight in how the different file format
structures work.
.
Name

Extension

Wire format

.wire

Polygon
Import

Polygon
Export

NURBS
Import

NURBS
Export

(Autodesk)
C4 format

.c4x

(Standard CAD)
IGES subset format.
STEP format

.stp

ISO standard industrial automation systems
product data representation and exchange
format.

.step

PTC Granite format (Windows Only)

.g

(PRO/ENGNINEER or any Granite based
system)

.prt (Pro/E part file)

JAMAIS format

.igs

.asm (Pro/E
assembly file)

(Standard CAD)
Japan Automobile Association IGES subset.
VDAIS format

.iges

(Standard CAD)
Verband des Automobilindustrie - IGES
Subset.
VDAFS format

.vda

(Standard CAD)
Verband des Automobilindustrie FlachenSchnittstelle.
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Name

Extension

DES format

.des

Polygon
Import

Polygon
Export

NURBS
Import

NURBS
Export

(Standard CAD)
Data Exchange Standard. Contains
polylines. Requires less space than
equivalent IGES files.
DWG format

.dwg

(AutoDesk)
Drawing Format.
DXF format

.dxf

(AutoDesk)
Drawing Exchange Format.
SLC format

.slc

(Solid Imaging)
3D Systems Slice format.
STL Format

.stl

(Solid Imaging)
3D Systems SLA file format. Used to send
data to a stereo lithography machine. Binary
and ASCII format.

CAI format for CATIA V4 files

(imports as
a mesh)

.cai

(CATIA)
CATIA Alias Inter operate ability file format.
CATIA V5 format

.CATPart
.CATProduct

OBJ format

.obj

(Autodesk)
Encapsulated Postscript format

.eps

(Standard)
VRML format
Virtual Reality Modeling Language
(3D Object Oriented Toolkit)
Pro/ENGINEER Render file format

70

.slp

(uses a
shell to
convert to
STL)

Name

Extension

IGES format

.iges, .igs

Polygon
Import

Polygon
Export

NURBS
Import

NURBS
Export

(SolidDesigner)
Initial Graphics Exchange.
OpenInventor format (Windows)

.iv

Illustrator format

.ai

Unigraphics par and assembly format

.prt

Wire format
The compressed proprietary file format used by Autodesk AliasStudio products.
Programmers can access wire file via the AliasStudio OpenModel library. In
AliasStudio you can open wire files from previous versions. If you continue to use
older versions of AliasStudio and want to keep the older file format intact, be sure
to copy the files before opening them, or rename the files after opening them.

IGES format
Initial Graphics Exchange Specification (IGES) is a neutral file format. This format
enabled different systems to transfer data without the need of a specific translator
on each system. AliasStudio uses IGES version 5.3.
The basic file structure of IGES contains five sections:
●

Start (S) section

●

Global (G) section

●

Directory (D) section

●

Parameter (P) Data Section

●

Termination (T) Section.

Pro/ENGINEER options for export and import
To make the import and export of IGES and STEP files easier for AliasStudio to
read.
1

In Pro/ENGINEER, select Utilities > Options

2

Add the following data to the configuration file.

IGES_OUT_ALL_SRFS_AS 128
IGES_OUT_SPL_CRVS_AS_126 YES
IGES_OUT_SPL_SRFS_AS_128 YES
IGES_OUT_MIL_D_28000 NO
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IGES_OUT_TRM_SRFS_AS_143 NO
IGES_OUT_TRIM_CURVE_DEVIATION DEFAULT
INTF_OUT_BLANKED_ENTITIES NO
INTF3D_OUT_EXTEND_SURFACE YES
INTF3D_OUT_FORCE_SURF_NORMALS YES
IGES_IN_106_F2_AS_SPLINE NO
IGES_IN_DWG_LINE_FONT YES
IGES_IN_DWG_PNT_ENT YES
IGES_IN_DWG_COLOR YES
FIX_BOUNDARIES_ON_IMPORT YES

VDAFS format
Verband des Automobilindustrie - VDAFS is a standard used for the transfer of
freeform shapes.
It was conceived for the transfer of freeform surfaces and their supporting
objects. This means the dimensions, layers, 2D geometry and text are left out.
This file format was logged as a National Standard in Germany (DIN 66301).
AliasStudio uses version 2.0 of VDAFS.
The basic file structure of the VDAFS format has a header section which gives
the general information about where, when, by who and how the file was created.
After the header, the entities are described one after the other.
The entity description has the following structure:
●

Entity name

●

Entity type

●

Parameter information, separated by comma's

●

Each line ends with a line number.

There are a limited number of entity types that can be used in the VDAFS
file. These entities only deal with the geometry and topology of elements.
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Entity type

Description

POINT

Point

PSET

Point Sequence

MDI

Point Vector Sequence
(Master Dimension)

CIRCLE

Circle/Arc

CURVE

Curve

SURF

Surface

CONS

Curve on Surface

FACE

Bounded Surface

TOP

Topology of a Surface

The only non-geometrical entities that can be used are the following:

Entity type

Description

HEADER

Header

$$

Comment

BEGINSET

Set - begin ~ group

ENDSET

Set - end

GROUP

Group

TMAT

Transformation Matrix

TLIST

Transformation List

Because of this limited number of entities, compared to the 500+ of the IGES
format, geometry is always defined using the same rules resulting in a lower
number of errors. On the other hand, you lose a lot of information that was
created in the originating system like layers but these can eventually be replaced
by groups, colors, dimensions, etc.

VDAIS format
Verband des Automobilindustrie - IGES Subset (VDAIS) is a well defined
collection of IGES entities, carefully selected for optimized exchange of geometry
between manufacturers and subcontractors in the car industry.

C4 format
IGES subset file format.

Unigraphics par and assembly format
Unigraphics is a solid modeling package based on the Parasolid kernel. The
package contains many (mostly optional) modules, for example CAD, CAM,
CAE, Sheet metal applications, knowledge bases, Quality control and Rapid
prototyping. The file structure is binary.
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The following table explains how common elements are called in both AliasStudio
and Unigraphics.
UG

AliasStudio

Segment

Span (curve)

Point

Point

Patch

Span (surface)

Pole

CV (Control vertices)

Sew

Stitch

U/V Grid

Patch Precision

Parameters

History

Control polygon (display
only)

Hull

Silhouette curve

Horizon curve

Blank

Invisible

Reference Set

Set

Category

Category

Custom view

Bookmark

Knot point

Edit point

Supported Unigraphics geometry and data mapping
The following sections describe the mapping process used for geometry types
and non-geometric data that can be transferred between AliasStudio and
Unigraphics.
>

Supported AliasStudio geometry types

The following AliasStudio geometry types can be exported to Unigraphics. Nongeometry entities such as Lights, Cameras, Textures, Windows, Animation are
not supported by the translator. The numbers in the table entries refer to Notes
for Unigraphics entities below.
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AliasStudio Entity

Unigraphics Entity

Construction Plane

WCS

Mesh

Not supported at this time.

Conic

Rational Curve

Arc

RationalCurve

Circle

RationalCurve

Line

Line

AliasStudio Entity

Unigraphics Entity

Curve

BCurve

Surface

BSurface; (1), (2)

Trimmed Surface

Face(1), (2)

Plane

Bounded Plane(1)

Shader

Colour Attribute(3)

Shell (Open)

Sheet Body

Set

Reference Set

Group

Group

Layer

Layer(4)

Category

Category

Shell (Closed)

Solid Body

>

Notes for Unigraphics entities

1

Unigraphics can not have free standing Surfaces so all surfaces are mapped
to faces which must be attached to a sheet body.

2

Surfaces having internal discontinuities will be split at those discontinuities.

3

Mapped as a Display Attribute of the mapped surface or shell.

4

Layer Name is not mapped

>

Supported Unigraphics Entity objects geometry types

The following Unigraphics geometry types can be imported to AliasStudio. The
letters and numbers in parentheses refer to Notes for AliasStudio Unigraphics
entity object entities below.
Unigraphics Entity Objects

AliasStudio Entity

WCS

Construction Plane

BSurface

Surface

Bounded Plane

Curve

Cylindrical Surface

Curve

Conical Surface

Curve

Tabulated Cylinder

Surface

Ruled Surface

Surface

Blended Face Surface

Surface

Surface of Revolution

Surface

Offset Surface

Surface

Sculptured Surface

Surface
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Unigraphics Entity Objects

AliasStudio Entity

BCurve

Curve

Line

Line(Curve)

Arc

Curve

Conic

Curve

Point

Point (Curve)(1)

Sheet Body

Shell (Open)(2)

Assembly

Groups/Instance(3)

Group

Group

Layer

Layer

Category

Category

Reference Set

Set

Part Attribute

Blind Data()

Solid Body

Shell (Closed)

>

Notes for AliasStudio Unigraphics entity object entities

1

A Unigraphics Point is converted to a degree 1 curve composed of two
coincident points. On export to Unigraphics this construction is converted back
to a Unigraphics point.

2

If the Sheet body only points to one face then this is converted to a trimmed
surface in AliasStudio.

3

This is a one way mapping, assemblies cannot be exported.
Added as blind data can be re-exported.

JAMAIS format
Japanese Automotive Manufacturers Association Iges Subset, JAMAIS is a file
format subset to IGES. JAMAIS has the same.igs extension and has exactly the
same file structure as the IGES format, it only supports less entities.
JAMA-IS:
●

does not include Dimensions

●

supports only a limited number of entities, optimized for the use in the carmanufacturing.

●

does not have the Surface Type option

●

does not have vendor tuned settings

The disadvantage of not supporting the above entities is that you can't put all the
different elements from an IGES file into AliasStudio. The advantage is that
because of the limited elements, there are fewer errors made when translating,
everything is optimized for the exchange of the specific models.
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PTC Granite format (Windows Only)
The Granite format is a new design of the DirectConnect Product for AliasStudio/
Pro/ENGINEER. This translator allows you to open, save as, export and import
Granite files.
Granite One is a CAD technology platform for the design collaboration of solid
models.
When importing a Pro/ENGINEER model into AliasStudio as template objects the
AliasStudio users can then modify the imported models. One AliasStudio object
corresponds with one Granite object. For example, if the AliasStudio wire file has
curves, surfaces, and shells, there will be different features created in the target
Pro/ENGINEER file for those curves, surfaces and shells.

When using the Granite translator AliasStudio models are converted to
Granite simple geometry features without construction history.

.Supported PTC Granite geometry and data mapping
The following sections describe the mapping process used for geometry types
and non-geometric data transferred between AliasStudio and Pro/ENGINEER
DirectConnect with PTC Granite support (Windows Only).
>

Exported supported AliasStudio object geometry types

The following AliasStudio geometry types can be exported to PTC Granite.

Non-geometry entities such as lights, cameras, textures, windows,
animation, construction planes, color, and layers which are not supported by
the translator.

AliasStudio Entity

PTC Granite Entity

Construction Plane

WCS

Polyset

Not supported at this time.

Point

Point

Conic

BSpline curve or bcurve

Arc

BSpline curve

Circle

BSpline curve

Line

Line

Curve

BCurve

Surface

Quilt of a face from a BSurface

Trimmed Surface Face

Quilt of faces of BSurface

Plane

Quilt of a face from BSurface

Shader

Not supported
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AliasStudio Entity

PTC Granite Entity

Shell (Open)

Quilt of face

Set

Not supported

Group

Not supported

Layer

Not supported

Category

Not supported

Shell (Closed)

Solid body

>

Imported supported PTC Granite Entity object geometry types

The following PTC Granite geometry types can be imported to AliasStudio.
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PTC Granite Entity Objects

AliasStudio Entity

WCS

Not supported

BSurface

Surface

Bounded Plane

Surface

Cylindrical Surface

Surface

Conical Surface

Surface

Tabulated Cylinder

Surface

Ruled Surface

Surface

Blended Face Surface

Surface

Surface of Revolution

Surface

Offset Surface

Surface

Sculptured Surface

Surface

BCurve

Curve

Line

Line(Curve)

Arc

Curve

Conic

Curve

Point

Point (Curve)

Assembly

Groups/instances

Group

Not supported

Layer

Not supported

Category

Not supported

Reference Set

Not supported

Part Attribute

Not supported

DES format
Design Exchange Specification (DES) format describes degree 1 curves
Polylines in DES format require less disk space than the same data in IGES
format.
The file structure is as follows:
●

The START line indicates the linear units system that is used.

●

The HEADER line contains a reference to the Userinfo.

●

The SENDING SYSTEM line indicates the type of preprocessor used.

●

The LINE indicates the start of a description of edit points for constructing a
first degree line. The parameters are grouped by three and represent the X,Y
and Z coordinates of the points that form the edit point of the lines. A new
description of a line always starts with the LINE entity, followed by the
number of lines, the number of edit points and a 0 to finish.

●

The DES file concludes with a * TERMINATE section.

●

Every line ends with a line number.

DWG format
The compressed proprietary file format used by Autodesk products.

DXF format
The Drawing Exchange Format (DXF) from AutoDesk is a verbose ASCII
geometry format capable of representing lines, simply defined surfaces, and
polygons (3D faces).
The file structure of a DXF file is divided into 4 main sections:
●

HEADER: identifying the system variables

●

TABLES: providing general information such as line style, user-defined
coordinate systems, etc.

●

BLOCKS: defining instanced blocks in the model

●

ENTITIES: describing the entities of the model

The above applies to the DXF format from Autocad 14

Each section is preceded by a group code 0, followed by the SECTION string, a
group code 2 and the type of section. A section is concluded with the 0
groupcode and the ENDSEC string. In each section, there are different items,
each consisting of 2 lines: the first to declare the nature of the item, the second to
define it's value. Each item in a DXF file takes a new line, therefore even the
description of a simple vertex takes up to 12 lines.
The group codes (GC) defines the nature of the value on the next line. There are
general and section specific group codes.
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STEP format
Standard for the Exchange of Product Data (STEP) is a ISO standard industrial
automation systems product data representation and exchange format.
The file structure for a STEP file has a modular structure which makes it easier
for developers to adapt the format to their own needs. The modules are called
“classes” and are classified using numbers as follows:
●

11-->13: Description methods: These classes describe the languages and
methods that are used to create a STEP file. Right now, only two description
method classes exit:
Part 11: The EXPRESS language reference manual.
Part 12: The EXPRESS-I language reference manual
The EXPRESS language is a data definition language that is used to
represent the structure of data and any constraints that may apply to it. The
information models contained in STEP Integrated Resources and Application
Protocols are defined using EXPRESS.

●

21-->26: Implementation methods: describe the correspondences between
STEP and other formal languages. (text encoding, C++ binding, ...)

●

31-->35: Conformity tests: used to check the degree of conformity of the
software associated with the Application Protocol.

●

41-->49: Integrated generic resources: the conceptual building blocks for
STEP

●

101-->106: Integrated application resources: contains the actual database,
the building block of the file. divided into generic resources and Application
resources

●

201-->233: Application protocols: contain all the branch-specific classes.

●

301-->332: Abstract test suites

●

501-->518: Application interpreted constructs Descriptions methods

STEP Application protocols
●
+ 201: 2D explicit technical design
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●

+ 202: 2D associative technical design

●

+ 203: configuration of mechanical parts and assemblies

●

+ 204: Brep 3D mechanical design

●

+ 205: Surface 3D mechanical design

●

+ 206: Wireframe 3D mechanical design

●

+ 207: Sheet Metal Die Planning

●

+ 208: Life Cycle Change Process

●

+ 209: Composite Structures

●

+ 210: PCA: Design & Manufacture

●

+ 211: Elect, Test, Diagnostics & Remfg

●

+ 212: Electrotechnical Plants

●

+ 213 : NC Process Plans

●

+ 214: Automotive design

●

+ 215: Ship Arrangement

●

+ 216: Ship Moulded Forms

●

+ 217: Ship Piping

●

+ 218: Ship Structures

●

+ 219: Inspection Process Plans

●

+ 220: PCA: Manufacturing Planning

●

+ 221: Functional Data & Schematic Rep. for Process Plants

●

+ 222: Design to Manufacturing for

●

Composite Structures

●

+ 223: Exchange of Design, and Manufacturing Product Information for Cast
Parts

●

+ 224: Mechanical Products Definition for Process Planning Using Form
Features

●

+ 225: Strctrl. Blg. Elements Using Explicit Shape Rep.

●

+ 226: Ship Mechanical Systems/Moulded Forms

●

+ 227: Plant Spatial Configuration

●

+ 228: Building Services: Heating, Ventilation, and AC

●

+ 229: Exchange of Design and Manufacturing Info for Forged Parts

●

+ 230: Building Structural Frame: Steelwork

●

+ 231: Process engineering Data: Proc Design & Proc Specs of Major
Equipment

●

+ 232: Technical Data Packaging

Each AP has its own subset of entities specific for the industry branch the AP
was developed for AliasStudio (supports the AP203 and the AP214.)
Application protocol support for STEP formats
The geometric descriptions contained within ISO10303-203 and ISO10303-214
are identical and comprises the core of the implementation of the translator. The
following table shows the mappings made by AliasStudio.
STEP Entity

AliasStudio Entity

Cartesian Point

Point

Line

B-spline Curve

Circle

B-spline Curve

Ellipse

B-spline Curve

Parabola

B-spline Curve

Hyperbola

B-spline Curve

PolyLine

B-spline Curve

Composite Curve

B-spline Curve (Grouped)

Trimmed Curve

B-spline Curve

B-spline Curve

B-spline Curve
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STEP Entity

AliasStudio Entity

Plane

B-spline Surface

Cylindrical Surface

B-spline Surface

Conical Surface

B-spline Surface

Spherical Surface

B-spline Surface

Toroidal Surface

B-spline Surface

Surface of Linear Extrusion

B-spline Surface

Surface of Revolution

B-spline Surface

B-spline Surface

B-spline Surface

Rectangular Trimmed Surface

Trimmed Surface

Curve Bounded Surface

Trimmed Surface

Offset Surface

B-spline Surface

Manifold Solid Brep

Shell (Closed)

Shell Based Surface Model

Shell (Open/Closed)

Pro/ENGINEER options for export and import

To make the import and export of IGES and STEP files easier for AliasStudio to read.
1

In Pro/ENGINEER, select Utilities > Options

2

Add the following data to the configuration file.

IGES_OUT_ALL_SRFS_AS 128
IGES_OUT_SPL_CRVS_AS_126 YES
IGES_OUT_SPL_SRFS_AS_128 YES
IGES_OUT_MIL_D_28000 NO
IGES_OUT_TRM_SRFS_AS_143 NO
IGES_OUT_TRIM_CURVE_DEVIATION DEFAULT
INTF_OUT_BLANKED_ENTITIES NO
INTF3D_OUT_EXTEND_SURFACE YES
INTF3D_OUT_FORCE_SURF_NORMALS YES
IGES_IN_106_F2_AS_SPLINE NO
IGES_IN_DWG_LINE_FONT YES
IGES_IN_DWG_PNT_ENT YES
IGES_IN_DWG_COLOR YES
FIX_BOUNDARIES_ON_IMPORT YES

CAI format for CATIA V4 files
CATIA is a CAD/CAM package. It contains modules for mechanical design,
analysis, shape design & styling, equipment and systems engineering, product
synthesis and infrastructure.
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CAI is based on the STEP standard. The translator, CATIA DirectConnect, is
created using the EXPRESS language from STEP. This file transfer system is
very specific and completely optimized, the CAI scheme has 31 entities.
The file structure for CAI is an adapted version of the STEP format to the needs
for converting CATIA and AliasStudio specific entities. This is indicated by the
file_schema ('CAI') declaration in the STEP file. For more information refer to the
STEP options.
CATIA geometry and data mapping
Use the following sections to identify the mapping process used for geometry
types and non-geometric data transferred between AliasStudio and CATIA via the
CAI file.
>

Supported AliasStudio geometry types

The following AliasStudio geometry types can be exported to CATIA. Nongeometry entities such as Lights, Cameras, Textures, Windows, Shaders and
Animation are not supported by the translator. The numbers in the table entries
refer to Notes for table 1 below.
AliasStudio Entity

CAI File Entity

CATIA Entity

Construction Plane

Axis(1)

8.1 3-axis system

Polyset

Not supported at this time.

N/A

Arc

RationalCurve

46.1 Rational B_spline curve

Circle

RationalCurve

46.1 Rational B_spline curve

Line

Line (partially supported) (2)

2.1 space line

Curve

BsplineCurve

3.2 B_spline polynomial space curve

RationalCurve

46.1 Rational B_spline curve

Face

FaceElement (3)

6.1 face

Surface

BsplineSurface

5.2 B_spline polynomial surface

RationalSurface

47.1 Rational B_spline surface

Target Surface

CrvSrf (4)

12.1 edge (curve on surface)

Trimmed Surface

FaceElement (5)

6.1 face

Trimmed Target Surface FaceElement and CrvSrf (l)

6.1 face and
12.1 edge (curve on surface)

Shell

OpenShell

13.1 skin
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>

Notes for table 1

1

The scale component of the AliasStudio Construction Plane is not transferred.
That is, its orientation and position will remain the same, but its size will not.
After a round trip translation (AliasStudio > CATIA > AliasStudio), an
AliasStudio Construction Plane with original scale values Sx, Sy, and Sz, will
return with scale values of 1, 1, 1.

2

A AliasStudio Line created by Curves > Line and related tools is not supported
on export to CAI as a CAI Line primitive, but is supported as a CAI
BsplineCurve. However, on import to AliasStudio of a CAI Trimmed Curve
whose basis curve is a CAI Line (this maps to a CATIA limited Line), an
AliasStudio Line is created. Such a Line will be exported as a CAI Line. This
ensures the original CATIA limited Line is preserved.

3

A AliasStudio Face element is converted to a Trimmed Surface temporarily
and then exported as such (see note (5) below).

4

A AliasStudio Target Surface contains one or more Curves-on-Surface. A
CrvSrf entity is exported for each curve-on-surface. On import to AliasStudio,
multiple CrvSrf entities that reference the same base surface will be converted
to one AliasStudio Target Surface containing multiple curves-on-surface that
correspond to these CrvSrf entities.

5

A AliasStudio Trimmed Surface is exported as one or more FaceElements
(one FaceElement for each region of the trimmed surface). On import to
AliasStudio, multiple FaceElement entities that reference the same base
surface are converted to a AliasStudio Trimmed Surface, with multiple regions
corresponding to these FaceElements.

●

A AliasStudio Trimmed Target Surface also contains curves-on-surface that
have not yet been used for trimming. Similar to the descriptions in Notes 2
and 3, it is exported as a combination of CrvSrf and FaceElement entities.

Identifying CATIA geometry and data mapping entities
To identify supported CATIA geometry and data mappings use the following
tables to identify the mapping process used for geometry types and nongeometric data transferred between AliasStudio and CATIA via the CAI file. The
definitions for the letters and numbers in parentheses is provided below the table.

This information is valid for CATIA version 4.1 not version5.

CATIA Entity

CAI File Entity

AliasStudio Entity

8.1 3-axis system (fixed)

Axis

Construction Plane

1.1 space point

Point

Curve and Locator (1)

2.1 space line (1)

Line

Line
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CATIA Entity

CAI File Entity

AliasStudio Entity

3.1 polynomial space curve (1)

BsplineCurve

Curve

46.1 Rational B_spline curve (1)

RationalCurve

Curve

4.1 plane

Plane

Surface (2)

BsplineSurface

Surface

5.2 B_spline polynomial surface

BsplineSurface

Surface

47.1 Rational B_spline surface

RationalSurface

Surface

12.1 edge (face boundary) (3)

OrientedEdge

Trim Curve (3)

12.1 edge (curve on surface)

CrvSrf

Target Surface (4)

6.1 face

FaceElement

Trimmed Surface (5)

13.1 skin

OpenShell

Shell

7.1 volume (4)

OpenShell(s)

Shell(s)

17.2 exact solid (5)

OpenShell(s)

Shell(s)

28.1 space ditto

Ditto

Instance (6)

3.2 B_spline polynomial space curve (1)
20.1 space circle (1)
21.1 space ellipse (1)
22.1 space parabola (1)
23.1 space hyperbola (1)

4.24 plane (2)
5.1 polynomial surface
0 unspecified
1 sphere
2 cylinder
3 cone
4 torus
5 unspecified surface of revolution
6 tabulated cylinder
7 ruled surface

>

Notes for CATIA entities in table 2

1

For all CATIA curves whose limits have been modified, a CAI Trimmed Curve
instance may be created when exporting.

2

For CATIA planar faces, some 4.24 planes may be transferred as they are
used as the base face surface.

3

The curve associated with the edge in CATIA is converted into a B-spline
Curve, used by the Oriented Edge. The parametric definition of the CATIA
edge is converted to a B-spline Pcurve used by the Oriented Edge.

4

The domains of the CATIA volume are converted to open shells.
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5

>

The Boundary representation of the solid is extracted and converted to CAI
elements (open shells, curves, etc.). Prior to exporting the exact solid, make
sure that this solid is up-to-date.
Notes for AliasStudio entities in table 2

1

A CAI Point is converted to a degree 1 curve composed of two coincident
points and a Locator that identifies the location of this curve. On export to CAI,
this construction is converted back to a CAI point.

2

A CAI Plane describes an infinite plane and is converted to a unit AliasStudio
Surface. This Surface will be re-exported as a CAI Plane.

3

The CAI Oriented Edge maps to a trim curve of a trimmed region of a
AliasStudio Trimmed surface.

4

A CAI CrvSrf entity maps to one AliasStudio curve-on-surface for a particular
surface. Multiple CAI CrvSrf entities in the CAI file referencing the same
surface will cause multiple AliasStudio curves-on-surface to be added to one
AliasStudio Target Surface.

5

A CAI FaceElement maps to one region of a AliasStudio Trimmed Surface. If
multiple CAI FaceElements in the CAI file reference the same surface, then a
AliasStudio Trimmed Surface will be created with multiple regions.

6

A CAI Ditto is imported as a AliasStudio instance node, with the CAI Ditto
transformation, of the AliasStudio group representing the CAI Detail (see
Supported Non-Geometric Data, Groups/Instances below).
However, if at least two CAI Dittos of the same CAI Detail each belong to
different parent CAI details, then those dittos are “exploded”. That is, each
geometric entity of the detail is copied and transferred by the transformation
of the CAI Ditto.

Supported non-geometric CATIA data
The following non-geometric data can be imported and exported between
AliasStudio and CATIA.
>

Groups/instances

How a AliasStudio Group is exported depends on whether it is instanced or not. A
AliasStudioGroup that is not instanced has its component geometry exported to
the appropriate independent CAI geometric entities. A AliasStudio Group node
that is instanced is exported as a CAI Detail entity (that is, the grouped
AliasStudio geometric entities become members of the CAI Detail); a AliasStudio
Instance node is exported as a CAI Ditto entity. CAI Dittos and Details are
subsequently imported into CATIA as CATIA Dittos and Workspaces,
respectively.
A AliasStudio Instance that contains a non-proportional (non-p) scaling factor in
its transformation is “exploded” on export (that is, each geometric entity that
belongs to the AliasStudio Group being instanced is copied and transformed to
independent CAI geometric entities). Only instances that contain a non-p scale
component are exploded. Other instances of the same group that do not have a
non-p scale component will export as CAI Dittos of a CAI Detail (as noted above).
CATIA Workspaces and Dittos can feature a situation that is not supported by the
AliasStudio dag structure and instancing mechanism. This situation arises when
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Dittos of the same Workspace belong to different parent Workspaces (see note
(6) in Notes for AliasStudio entities in table 2 above). The CATIA Ditto/Workspace
structure is preserved as best as possible on CAI export from CATIA and
subsequent import back to CATIA.
>

Names

AliasStudio DAG node names are exported as an attribute of the CAI entity to
which the node’s geometry maps. AliasStudio Instance node names are exported
as an attribute of the CAI Ditto; the corresponding CAI Detail will have the name
of the instanced AliasStudio Group node. The name attribute of a CAI entity is
mapped to the CATIA User Identifier for that entity in CATIA.
On CAI import to AliasStudio, it is possible for multiple CAI entities to map to a
single AliasStudio object (see notes (4) and (5) in Notes for AliasStudio entities in
table 2 above). Each of these CAI entities may have a unique name (CATIA User
Identifier), but the AliasStudio object can only have one name available for
viewing and editing. The CATIA User Identifiers that are not mapped to a
AliasStudio object with a modifiable name are maintained by AliasStudio for
subsequent export to CATIA via CAI, assuming the objects to which the names
are assigned still exist.
For example, a CATIA user can name individual Faces that all reference the
same surface. These Faces map to CAI FaceElements which in turn map to trim
regions of a single AliasStudio Trimmed Surface. Only the trimmed surface node
can have a name, and this is given the name of the underlying CATIA surface
being trimmed. The CATIA User Identifiers of each of the faces that mapped to
trim regions are maintained within AliasStudio so they can be transferred back to
CATIA. A similar situation exists for multiple CAI CrvSrf entities that map to one
AliasStudio Target Surface. The CAI CrvSrf name attribute is preserved for
export back to CATIA.
AliasStudio generated names of the form node#<n> (for example, node#5) are
not exported to CAI. CATIA generated names of the form *<OBJ><N> (for
example, *FAC5) are not exported to CAI. CAI entities that do not have names
are given a system generated name on import to AliasStudio or CATIA.
>

Layers

The AliasStudio Layer assignment is preserved when exporting to CAI. As with
names, the layer number becomes an attribute of CAI geometric entities and
Dittos. The layer name and other AliasStudio Layer attributes are not exported.
On CAI import to AliasStudio, geometric entities are placed on the layer defined
by the CAI layer number attribute. If the layer is created by the import process, it
is given the name CATIA_<N> where <N> is the layer number. All layers created
by the CAI import process are sorted in the layer bar by ascending number.
As with the name attribute, the layer number assignment for CAI FaceElement
and CAI CrvSrf entities is preserved on CAI import so that this information can be
returned to CATIA through CAI even though it cannot be modified in AliasStudio.
In AliasStudio, a geometric object and all of its ancestors in the dag hierarchy
must be in the same layer. In CATIA, this is not necessarily the case, as a Ditto
may be in a different layer than the components of the instanced Workspace. On
CAI import to AliasStudio, this feature of CATIA layers is maintained for
subsequent export back to CATIA. If you change the layer assignment of an
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AliasStudio Instance that was created from a CAI Ditto, you will change the layer
assignment of all the geometric entities being instanced to this new layer number
within AliasStudio. However, on CAI export, the original CATIA layer number
assignments for the component geometric entities and Ditto will be used.
CATIA Dittos that are not assigned to a layer will be preserved through a bidirectional CAI translation with AliasStudio. While in AliasStudio, these Dittos will
be imported as AliasStudio instances that reside in the Default Layer.
>

Object colors

The wireframe display color of CATIA objects is preserved in a bi-directional CAI
translation with AliasStudio, providing the CATIA model uses the CATIA Standard
Color Table. If the model references a user-defined color table, then on CAI
import to CATIA, the CAI color of each element is chosen from the standard color
table as the closest match to the original color.
As with names and layers, the CATIA wireframe color index of an object is an
attribute of the CAI geometric entity. On CAI import to AliasStudio, the CAI
geometric entity’s color index is converted to an RGB color based on the CATIA
Standard Color Table. This RGB color is used to create a simple shader that is
assigned to the associated AliasStudio object that is created, unless the object is
a curve. Only for curves is the CATIA wireframe color index preserved. CAI
surface geometry that has no CAI color attribute is assigned the AliasStudio
default shader.
On AliasStudio export to CAI, the color index of a CAI geometric surface is
determined by finding the index in the CATIA Standard Color table that
represents the closest match to the RGB color of the associated AliasStudio
shader. For non-surface CAI entities, the preserved CATIA color index is
exported if it exists. For original AliasStudio curve geometry, the layer color is
used to find a close match to a CATIA Standard Color index.
>

Layer colors

Layer colors are not transferred explicitly via the CAI format. However, layer
colors are assigned to layers created as a result of CAI import by one of two
possible methods.
In the first method (the default) a created layer is assigned one of the 15
available colors based on the remainder of the layer number divided by 15. This
cycles through the available AliasStudio layer colors as the layer number
increases.
The second method uses the CATIA Standard Layer Color Table which is defined
in the CATIA environment’s startup initialization file CATINSTD.dcls. If this file
exists in the /usr/aw/alias/.Alias/ directory of the AliasStudio installation, or in
the.Alias/Prefs.1/Color/ directory of the AliasStudio user account, then the CATIA
Standard Layer Color Table will be extracted from this file by the AliasStudio CAI
import process and used in the layer color assignment process.
The CATIA Standard Layer Color Table assigns to each of the 256 CATIA layers
a default CATIA color index whose RGB color is defined in the CATIA Standard
Color Table (see Object colors above). When the AliasStudio CAI import process
has access to this default layer color assignment, it assigns a color to a newly
created AliasStudio layer that closely matches the color for that layer number in
the table.
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To activate this second method copy the CATINSTD.dcls file from the CATIA
installation to /usr/aw/alias/.Alias/ or to the .Alias/Prefs.1/Color
directory of your user account. Alternatively, create a symbolic link, in either of
these AliasStudio directories, to the CATINSD.dcls file in the CATIA installation.
For example, if AliasStudio is installed in /usr/aw and CATIA is installed in /
usr/catia, then the following command will create the necessary symbolic link:
ln -s /usr/catia/cfg/dec/CATINSTD.dcls /usr/aw/alias/.Alias/
CATINSTD.dcls

What happens when creating a skin and offsetting for CATIA?
Creating a ‘skin’ and ’offsetting’ (or creating solid geometry from imported
AliasStudio models) is a common workflow when integrating AliasStudio and
CATIA. When exporting the model from AliasStudio, you must ensure that the
geometry is built to the correct tolerance and that it can also be stitched. The
stitching process in AliasStudio identifies gaps between surfaces so that you can
repair the appropriate geometry before writing the file out to CATIA.
During stitching, the surfaces are twinned. This means that the surface
boundaries may be split to accommodate adjacent surfaces, and periodic
geometry is detached into multiple surfaces. For this reason, you should save the
AliasStudio wire file before stitching so that if further modifications are required to
be made to the AliasStudio model, the construction history will be intact.

CATIA V5 format
The following entities are translated into CATIA V5 format.
Studio entity

saved to CATIA V5 format as

Curve (created
with either CVs
or Edit Points)

NURBSCurve of appropriate degree

Line

Line

Arc

NURBSCurve

Circular

NURBSCurve. Note that periodic objects
will be divided into two.

Blend curves

NURBSCurve of appropriate degree.

Multiknot curve

NURBSCurve

Curve on
surface

NURBSCurves

Surface

NURBSSurface.

Surface Revolve NURBSSurface. Periodic objects will be
divided into two.
Multiknot
Surface

Surfaces divided in multiple surfaces if -d
option is used.
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Studio entity

saved to CATIA V5 format as

Shell

Solid. Caution: Alias closed shell
becomes a CATIA Solid. If -s option is
specified, the shell’s faces will become
surfaces.

sphere, cone,
cube, etc.

NURBSSurface. Periodic objects are
divided into two.

Rational sphere, NURBSSurface. Periodic objects are
cone, etc.
divided into two.
Planar face

NonRationalNURBSSurface of degree 1
with a single span in U and V directions.
Faces with holes will be transferred.

Shell

CATIA solid body, if shell is closed, or
skin (open shell) if shell is open.

Surface with
Multiple trimmed surfaces
multiple disjoint
trimmed regions
Closed periodic
curve

Periodic curves are divided into two
curves.

Shader Color
RGB

Color RGB

Layer

Layer (numbered). Layer name is
ignored.

Invisible

Invisible (no show)

Construction
vector

Line

Construction
plane

Plane

Symmetry

Converted if -b option for layer symmetry
is ON.

Space point,
Curve point,
Surface point,
Curve-onsurface point

Point

The standard document types provided by Dassault Systemes are:
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●

Part Document

●

Product Document

●

Drawing Document

●

Material Document

●

Catalog Document

●

Analysis Document

●

Process Document

A Part Document has a .CATPart suffix, and is mainly used during the design
process. The Part Document is used as the default document type for the
following workbenches:
●

Mechanical Design: Part Design, Sketcher, Sheet Metal Design, Wireframe &
Surface Design, Functional Dimensioning & Tolerancing.

●

Shape: Free Style, GSM Debug, Digitized Shape Editor, Generative Shape
Design.

●

Equipment & Systems: Circuit Board Design.

A Product Document has a .CATProduct suffix, and is mainly used to assemble
Product or Part documents in a structured, coherent system of sub-products and/
or parts. The Product Document is used as the default document type for the
following workbenches:
●

Infrastructure: Product Structure, Knowledge Advisor, Knowledge Expert,
Generative Knowledge, Product Engineering Optimizer, Rendering.

●

Mechanical Design: Assembly Design, Structure Design.

●

AEC Plant: Plant Layout.

●

Digital Mockup: Navigator, Space Analysis, Kinematics, Fitting, Plant & Ship
Review, Optimizer, Tolerancing Review.

●

Equipment & Systems: Systems Space Reservation, Systems Routing,
Electrical Wire Routing.

●

DELMIA Infrastructure: Digital Manufacturing ReView.

OBJ format
The OBJ file format is a ASCII form. It supports a variety of geometry ranging
from polygons to high degree NURBS surfaces.
The following types of data may be included in an OBJ file. In this list, the
keyword (in parentheses) follows the data type.
>
●

Vertex data
geometric vertices (v)

●

texture vertices (vt)

●

vertex normals (vn)

●

parameter space vertices (vp)

>
●

>
●

Free-form curve/surface attributes
rational or non-rational forms of curve or surface type.
Basis matrix, Bezier, B-spline, Cardinal, Taylor (cstype)
degree (deg)

●

basis matrix (bmat)

●

step size (step)

>
●

Elements
point (p)
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●

line (l)

●

face (f)

●

curve (curv)

●

2D curve (curv2)

●

surface (surf)

>
●

Free-form curve/surface body statements
parameter values (parm)

●

outer trimming loop (trim)

●

inner trimming loop (hole)

●

special curve (scrv)

●

special point (sp)

●

end statement (end)

>
●

>
●

Connectivity between free-form surfaces
connect (con)
Grouping
group name (g)

●

smoothing group (s)

●

merging group (mg)

●

object name (o)

>
●

Display/render attributes
bevel interpolation (bevel)

●

color interpolation (c_interp)

●

dissolve interpolation (d_interp)

●

level of detail (lod)

●

material name (usemtl)

●

material library (mtllib)

●

shadow casting (shadow_obj)

●

ray tracing (trace_obj)

●

curve approximation technique (ctech)

●

surface approximation technique (stech)

Encapsulated Postscript format
You can control what to retrieve from an EPS file.

You cannot import into AliasStudio EPS files that were created using the SGI
Showcase program.
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OpenInventor format (Windows)
OpenInventor is an object-oriented C++ based language that describes complete
3D-scenes which can be made interactive and that are optimized for OpenGL. It
is an ASCII file format.
Inventor can be seen as a complete toolkit, consisting of:
●

a library of (3D) objects

●

a library of modules and utilities

●

an API in C/C++ for programming

The Inventor language contains a large set of predefined objects called nodes
such as geometry, properties, groups and manipulators.
These nodes are ordered using a scene graph which describes the hierarchy of
the nodes. This means that you can have certain objects in the beginning of the
file whose behaviour or properties influence other objects.

Inventor file that is exported from AliasStudio does not contain a scene
graph.
●

Each nodes is defined by the following set of parameters:

●

Nature: a geometrical object (for example,. cube, cylinder, and sphere),
texture maps, cameras, lights.

●

Fields: contains info on the size, and file for the texture maps.

●

Name: Nodes can be referenced by a name. A name is not absolutely
needed.

●

Child nodes: every node can contain other nodes. This node is called a
group node.

3D scenes can be constructed containing not only 3D geometry but also lighting,
texturing, different camera settings.and animation (A node can also be a
transformation). Nodes can also be references to files (for example, images) and
external programs, like Midiplayers or WAV-players.
To have interactivity with the scene, special nodes like draggers, action nodes
and manipulators are included.
>

Examples of nodes that can compose a scene and provide interactivity

Shape nodes: Cube, Cylinder, Cone, Sphere, Face set, Text2, Line, NURBS,
Quad mesh.
Property nodes: Base color, Color index, Complexity, 3D and 4D coords,
Environment (e.g. fog, haze, light), Font, Lighting model (Base color or Phong),
Material, Normal, Pick Style, Texture, Texture Coordinates, Transform, Units.
Group nodes: Annotation, Array, File, Group, Level of detail, Multiple copy.
Actions nodes: Callback, GL render, Get bounding box, Handle event, Highlight
render.
Engine and Sensor nodes: Blinker, Engine classes, Pendulum, Rotor, Sensor
classes, Shuttle (oscillation).
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Interactive 3D Manipulator nodes: Centerball (rotation), Drag point, Handle box
(scaling, translation), Light draggers, Rotate draggers, Scale draggers.
Other nodes: Clip plane, Directional light, Label, Orthographic camera,
Perspective camera, Point light, Spot light.
Now by using the Open Inventor file format and API, you can speed up the
programming of OpenGL up to 10 times, and Inventor-viewers (like ivview) are
designed specifically for use with OpenGL, resulting in very fast display of the
scenes contained in the Inventor file.

Illustrator format
You can control what to retrieve from an Adobe Illustrator file.

Only up to Ilustrator version 8 is supported.

By setting File > Import > File Illustrator options, you can enable AliasStudio to
import the geometry as a Group of curves or as individual curves. You can also
Scale the image before importing it into AliasStudio.
When saving an Illustrator file choose File > Print setup, set Output to File and
set the Output Style to Illustrator. The output results transfer the paint and
shapes information. The results of opening this file in Illustrator is a display of
three objects:
●

the image plane displaying the final image (image plane).

●

the curves that defines the shape.

●

the shapes of the model which can be individually selected and manipulated.

If you want to change the geometry of the AliasStudio model in Illustrator,
export the model as a Post Script file from AliasStudio. Open this file in
Illustrator to manipulate the polygons.

VRML format
VRML (Virtual Reality Modeling Language) was developed with the intention of
providing people with a standard tool that they could use to view and interact with
3D models on the Web.
The file structure of the VRML files is based on the Inventor format where there is
a hierarchical arrangement of nodes.
VRML 2 resembles to the structure of VRML1 but uses slightly different
keywords. E.g. vertex becomes point, DEF Default shader group becomes
material DEF Default shader Material.
Features
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●

Cameras are converted to VRML2.0 Viewpoints.

●

Ambient Lights are converted to a VRML point light with ambient properties.

●

Per-vertex normals and texture coordinates (if desired).

●

Material animation is converted.

●

Animation is converted intelligently (only dynamic objects have animation
information).

●

Initial navigation mode can be specified in the translator.

●

Double-sided/single-sided setting (in Render stats) is converted for groups.

●

Does not support VRML2.0 embedded textures.

●

The Inventor/VRML translator does not support annotation information.

These are the main differences between VRML 1 and VRML 2:
Version

Differences

VRML 1.0

Standard objects (cube, sphere, cone, cylinder,
text)
Arbitrary objects (surfaces, linesets, pointsets)
Ability to fly through, walk through, examine
scenes
Lights
Cameras (viewpoints)
Textures on objects
Clickable links
Define and reuse objects

VRML 2.0

Animated objects

All VRML
Switches
1.0 features
Sensors
plus
Scripts (Java and JavaScript)
Interpolators (colors, position, orientation, etc.)
Extrusions
Background colors and textures
Sound (.wav and MIDI)
Animated textures
Event routing
Define and reuse objects and behaviors and
effectively add new nodes to the language with
PROTO and EXTERNPROTO
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To view and interact with VRML, you need a plug-in for your web browser
which interprets the VRML language and makes the objects visible on the
screen.
Examples of web browsers:
- Cosmoplayer
- Worldview
- Microsoft VRML 2.0 viewer
- Webscout (VRML1)
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