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Optimizing Standard Parts

In This Exercise
By using the predrawn standard parts in AutoCAD Mechanical, 
you can create your designs more quickly and accurately. Here, 
you learn how to fully optimize the standard parts for day-to-day 
work.

This Skill Builder demonstrates how to: 

■ Install custom standards.

■ Configure standard parts settings.
 

■ Limit the number of standard parts displayed to optimize
performance.

■ Set up custom standard parts using the VAL-editor to
optimize the usage on standard parts.

Custom Standards Installation
You must know which standard you plan to use for your projects to include them during the initial installation 
of AutoCAD Mechanical (for example, ISO, ANSI, DIN, and so on).

Select the Custom option during the installation for the required standards in your designs. You can turn off 
standard parts that your company rarely uses and reduce the time required to select the appropriate 
standard part.
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Next, use the Standards Setup dialog box to select the required standards. The default settings are ANSI, 
ISO and DIN Standards. You can switch off DIN standards if your company uses mainly ANSI and ISO 
standards.

System Setting for Standard Parts
Start to familiarize yourself with the AM:Stardard Part setting. From the pull-down menu, click Assist > 
Options > AM:Standard Parts tab or command: AMOPTIONS > AM:Standard Parts tab to set up the 
standard parts.

A - Database; B - 2D representation; C - 3D representation
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Database
You can specify the database configuration file path, local filters for selection group, and required standards 
for your design.

■ Database Configuration File
Displays the path to standard parts. Browse to select a file that contains standard parts.

■ Local Filters
Configure your project’s standard parts group based on company, industry standard, both or all 
standards in the local filters column.

- Preselection
Specifies which preselection filter group the standard parts belongs to. The following options display in 
each of the preselection filter modes:

All = S, A, C, and N
Standard = S and A
Company = C and A
Company and Standard = A

NOTE:   You can create four groups of standard parts in the Value Table of the standard parts database. 
        Select S to make the size available for the "Standard" preselection filter, C for the "Company"
         preselection filter, A for all preselection filters and N for none.

Company - C
Standard - S
Company and Standard - A
None - N (groups of standard parts you do not want to display for selection.)

- Selection Group
Sets the hole type to Close, Normal, or Loose and Thread type to Fine or Regular.

- Available Standard
Displays all standards installed on your system.

- Selected Standard
Selects the required standard (for example, DIN and ISO) to be used for your design when you do not 
need other standards.

- Add old Standard Designations
Displays both old and new designations for parts in the Standard Part Value Table.
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To define which sizes of standard parts group to be available for design work

1.  From AutoCAD Mechanical, click Assist > Options to display the Options dialog box.

2.  Click the AM: Standard Parts tab.

3.  Select Company standard at the preselection filter menu.

4.  Select ANSI standard.

5.  Click OK to close the Options dialog box.

6.  At the command prompt, type Amstdplibedit to open the Edit Standard Parts Database dialog box.

7.  Navigate to the subset folder. Click Standard Systems > ANSI Standard system > Fasteners > Screws 
and Threaded Bolts > Socket Head Types > Hexagon Socket Button Head Cap Screw - UNC (Regular 
Thread - Inch).

8.  Click Edit Valuetable.

9.  Scroll to ID Number G_740, switch the part status for G_740 through 800 to Company - C standard. See 
the following image.
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10.  Switch the part status for ID Number G_810 through G_830 to Standard - S. See the following image. 
Next, close the dialog box.

To insert a 1/4” - 20 UNC screw based on Company Standard

1.  At the command prompt, type Amstdplib.

2.  Click Standard Systems > ANSI Standard system > Fasteners > Screws and Threaded Bolts > Socket 
Head Types > Hexagon Socket Button Head Cap Screw - UNC (Regular Thread - Inch).

3.  Click Front view, and click a point in the model space to specify the insertion point.

4.  Select size - 1/4” -20UNC.

5.  Notice only Company standard sizes are available.

6.  Place the screw.
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7.  Use the PowerEDIT command to change the screw’s size. (From pull-down menu, click Modify > Power 
Commands > Power Edit.)

8.  At the drag size prompt, press Enter to display Select Part Size dialog box.

9.  Notice that only Company Standard sizes are displayed and available for selection.

10.  Those screw ID number G_810, G_820, G_830 with part status - S (Standard) are not available for 
selection.

2D Representation
Set the 2D representation or appearance of the standard parts.

■ 2D Hide button
Displays standard parts with or without invisible hidden line.

■ Auto Hide Background
  Hides objects behind the standard parts.

■ Draw Centerlines
  Creates standard parts’ centerlines.

■ Representation
  2D representation of the standard parts (for example, symbolic, standard or simplified).

■ Layer Groups
  Specifies layer groups to be used for standard parts.

■ Use Standard parts Layer
  Uses the predefined standard parts layers for the standard parts.
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■ Use Hidden Layer for Front View of Features
Uses the hidden layer for the front view of features. See image below.

3D Representation
Sets the 3D representation or appearance of the standard parts.

■ Enforce Projection Length Rules for Screw Connection
Sets the projection length of centerlines for screw connections to follow a rule similar to that of VDI 2230, 
where the projection length of the screw centerline should have a length of 1.5 times the length of the 
nut associated with it.
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Optimizing Performance for Standard Parts
Time taken to display Standard Part Selection dialog boxes vary with the number of standards selected or 
displayed when standard parts are used. When all the standards are selected, performance is slower 
because the entire database is sorted to display the associated part information.

Method 1: Reducing the Number of Standards Displayed
You can optimize the performance by minimizing the number of standards displayed. To shorten the display 
time of standard parts for design, you do not need to display all standards. 

Tip: It is recommended to select only those standards for display that you use frequently. For example, in 
the U.S. market, you can select to display only the ANSI and ISO standard parts.

Limit the number of standards and standard parts displayed
1.  From AutoCAD Mechanical, click Assist > Options to display the Options dialog box.

2.  Click the AM: Standard Parts tab.

3.  Select the unused standards and move them to the available standard column. Retain the frequently 
used standards in the Selected Standard list by using the left and right arrows. Use the up and down 
arrows to adjust the display order of each standard.

4.  Click OK to save the current setting and close the Options dialog box.

5.  The next time you attempt to insert a standard part, only the DIN standard parts will be displayed. Since 
the number of standard parts to load has reduced, the dialog box opens much faster.
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6.  Click the Standard Parts icon or command: AMSTDPLIB. Notice that only the DIN standard displays for 
all standard parts when you click any other standard parts like the steel shapes, springs and others.

NOTE: All installed standard parts based on the selected standards are displayed in this dialog box for 
inserting into the drawing. Use the AMSTDPLIBEDIT command to edit the standard part 
identification and physical properties if required.

Method 2: Limit the Parts shown in Selected Standard System Settings
You can switch off the standard parts that you do not use in the current project. To accomplish this, use the 
following procedures before working on the standard parts.

Switching off Unused Standard Parts

1.  At the command prompt, type Amstdplibedit to open the Edit Standard Parts Database dialog box.

2.  Expand the standard trees to Standard Systems > DIN Standard System > Fasteners > Screws and 
Threaded Bolts > Countersink Head Type or the standard parts that you want to switch off for your 
design.

3.  Click DIN 924 (Regular Thread), and click Inactivate. Do the same for DIN 925 (Regular Thread).



10

4.  The next time you place a countersink head type screw, both DIN 924 and DIN 925 standard are not 
available for quick selection.

5.  To enable and display the parts, follow steps 1-3.

TIP: From the Content menu, select Change Representation or type AMSTDPREP in the command line 
to change the representation to Simplified, Symbolic or Standard.
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Customize standard parts using VAL-editor
You can add new custom standard parts to the existing standard parts database by using the Val-editor (for 
example, to use different materials or sizes for the standard parts).

First, you must know the location of standard parts database value table for the standard part you customize 
for your designs.

Location of Standard Parts Database Value Table
1.  Use the AMSTDPLIBEDIT command to open the Edit Standard Part Database dialog box; or from the 

Assist pull-down menu, click Options > AM: Standard Parts tab. Click EDIT to start the Edit Standard 
Parts Database dialog box.

2.  Expand the tree, and select the subset.

3.  Click Edit Valuetable.
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4.  Notice the VAL filename at the top left corner of the dialog box. The VAL file name in the following image 
shows is2403.val for the countersink head ISO 2009 regular thread screw.

NOTE: The VAL files are stored in the ACADM\GEF\GDB\. GDB - global database folder. The database 
contains the description of the standard parts and the paths where the parametric files (GPL 
format) are saved.

Customize a Material in the Standard Part Content
Before you begin, back up the original VAL table (di0001.val) before adding a new material to the washer.

1.  Type AMSTDPLIBEDIT at the command prompt.

2.  Select DIN Standard System > Fasteners > Washers > Plain > DIN 125-1 A.

3.  Select DIN 125-1 A, and the click the Edit Value table.

4.  In the VAL Editor, click the NND Nominal Diameter Column, right-click, and then click Append Column.

5.  Under the Column Type, make sure that the new column is Normal so you can set the default value at 
the Default Value box in the VAL-editor dialog box. If the entire column is to contain a single constant 
value, select Global. If the column is to contain a calculated value based on formula, select Calculated.

6.  In Column Name, enter Mat_1
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7.  Under Position in Bill of Material, select Material1 so it is used as the default material.

8.  Click OK to save and close the dialog box.

9.  On the 12th row (Norminal Diameter is 7mm), enter Brass under material column.

10.  Save and close the VAL Editor.
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Insert a Washer - DIN 125-1 A
1.  Click Assist > Options > AM:Standards.

2.  Under Standards, select DIN and double-click BOM support.

3.  Make sure the Material is set to Visible in BOM.

4.  Type AMSTDPLIB at the command prompt.

5.  Navigate to the Fasteners > Washers > Plain > DIN 125-1 A.

6.  Click the Front View icon, and place the insertion point of a 7mm washer.

7.  Click Annotate > Part List Tools > Part List to place the part list.

8.  Notice the material displays Brass for the washer in the list.
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Adding User-defined Size to the Standard Part
You may need to customize the existing standard parts for a newly defined size that is not found in the 
database. The following example shows you how to add an ANSI 1/4-20 x 1 3/8 inch Hexagon Socket Button 
Head Cap Screw - UNC (Regular Thread - Inch) to the standard parts database.

1.  Type AMSTDPLIBEDIT at the command prompt.

2.  Navigate to the subset folder. Click Standard Systems > ANSI Standard system > Fasteners > Screws 
and Threaded Bolts > Socket Head Types > Hexagon Socket Button Head Cap Screw - UNC (Regular 
Thread - Inch).

3.  Click Edit Valuetable to start the VAL-Editor.

4.  Scroll down to search for RID ID Number G_800 (1/4-20 x 1.1/4) screw.

5.  Select the entire row by clicking the row at the left.

6.  Right click to select Insert Row.

7.  Copy (Ctrl + C) and paste (Ctrl + V) all the data, with the exception of the RID (ID Number), from the row 
you selected in step 4. (Note: Do not click on any cell while holding the left mouse button to select the 
entire row.) 

8.  Change the description for the newly added screw to 1/4-20 x 1.3/8.

9.  In the Nominal Length column, change the value to 1.37500.

10.  Save and close the VAL-Editor table.

11.  Now you have an additional ANSI 1/4-20 screw in the standard parts list.

 


