home login search menu close-circle arrow-dropdown-up arrow-dropdown arrow-down arrow-up close hide show info jump-link play tip external fullscreen share view arrow-cta arrow-button button-dropdown button-download facebook youtube twitter tumblr pinterest instagram googleplus linkedin email blog lock pencil alert download check comments image-carousel-arrow-right show-thick image-carousel-arrow-left user-profile file-upload-drag return cta-go-arrow-circle circle circle-o circle-o-thin square square-o square-o-thin triangle triangle-o triangle-o-thin square-rounded square-rounded-o square-rounded-o-thin cta-go-arrow alert-exclamation close-thick hide-thick education-students globe-international cloud sign-in sign-out target-audience class-materials filter description key-learning pdf-file ppt-file zip-file plus-thick

Worldwide Sites

You have been detected as being from . Where applicable, you can see country-specific product information, offers, and pricing.

Change country/language X

Keyboard ALT + g to toggle grid overlay

System Requirements

System requirements for Buzzsaw

Buzzsaw app for Microsoft® Windows®

  • Microsoft® Windows® 7 or Microsoft® Windows® XP Professional edition operating system
  • Intel® Pentium®-based PC or compatible
  • 2 GHz processor or higher
  • 35 MB free disk space
  • VGA video display of 1,024 x 768 or higher
  • Microsoft® Internet Explorer® 7 or higher web browser
  • DSL, cable, or equivalent broadband Internet connection

Buzzsaw web access requirements

  • PC or Apple® Macintosh® computer with DSL, cable, or equivalent broadband Internet connection
  • Internet Explorer 7 or higher, Firefox® 4 or higher, Apple® Safari® 5 or higher, or Google Chrome™ 10 or higher web browser

Buzzsaw Professional web access requirements

  • PC computer with DSL, cable, or equivalent broadband Internet connection
  • Internet Explorer 7 or higher web browser

Buzzsaw mobile app for Apple® iPhone® and iPad®

  • iOS 4.2 or higher

Buzzsaw mobile app for Android™ Phone or Tablet

  • Android OS 2.2.1 or higher